Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: Z97 Extreme4 - No USB issue after update.




  1. #1
    Britgeezer is offline Member
    Join Date
    Nov 2013
    Location
    New Jersey
    Posts
    162

    Default Z97 Extreme4 - No USB issue after update.

    Thought I would try the APP Shop and do some updates, disaster. Can anyone read the text in the display?

    Anyway, with much squinting I saw a couple of updates including USB 3.0 and went ahead with that and a couple of others ME and Inf I recall.

    Net result is PC will not boot properly.

    1. USB KB and Mouse work in BIOS, but not when PC boots into windows.
    2. CCleaner wants permission to load but I can't give a yes or no since I have no KB or Mouse.
    3. Safe Mode is the same. No KB or mouse
    4. Repair can't fix it and wants me to send a message to MS, but I can't click yes or no.
    5. System repair / recovery for the PC will start but can't continue - no mouse or KB input.
    6. I even tried the installation disk, same issue can't navigate the menu - no mouse or KB.


    I'm plugging in to the USB 2.0 headers but obviously 3.0 is not working either.

    The only thing I can think of is to clear the CMOS and set default in BIOS.

    I have backups of the OS if I can just get the Mouse and KB to work. Of course I threw away any PS2 mouse or adapter months ago.

    Any ideas?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Extreme4 - No USB issue after update.

    Yeah, got a USB to PS2 adapter... oops, sorry. Do you have any cheapo mouse you can try?

    In the BIOS, USB Configuration, try the USB Compatibility Patch option, or any of the other USB options for a desperate fix attempt.

    Did you try disconnecting and connecting the mouse and keyboard while Windows is booted? If they are wireless, remove the USB transmitter from its USB port, and power cycle the mouse and keyboard if possible, via removing a battery if necessary.

    If that works for you, a Windows Restore point, if you have that enabled, will allow you to start over before all the nonsense started.

    I've been wanting to... discuss the APP Shop software for a while now. Not that I have tried it, thank Gawd apparently that I didn't (imagine a BIOS update if it is that bad) but really another situation that seems to exist that is related to it. (I'm wondering now if your inability to read it caused you to select something inappropriate to be installed, but what would that be that caused your problem is beyond me.)

    It seems that ASRock is forcing APP Shop upon us. Until recently, the ASRock website that has all their mother board information had a link at the top of most if not all pages, titled Download. From that page there were links to the Latest BIOS Updates, Latest Driver Updates, etc. It looked just like this:

    Z97 Extreme4 - No USB issue after update.-asrock-download-page-png

    I have a bookmark in my browser to that page, but the link at the top of the pages I mentioned above no longer exists. Plus it appears that the download pages are no longer being updated as of the end of March. Nothing new has been added for almost a week now.

    The previous download links with the BIOS, Driver, and Utility update lists was very convenient for finding new things, particularly if you own several ASRock boards as I do. Plus driver updates for one board may be applicable to other boards, which allows us to know if new drivers are available before our board's page is updated. I checked the lists almost every day, if only to see what was happening with other boards.

    Now that great and simple way of finding updates is gone, or have I just lost my mind?

    Are we now stuck using APP Shop for updates? Driver downloads for Dummies? I really do not like the concept of insulating the user from the drivers, etc, as these automated driver update programs do. Sure they are good for the non-PC enthusiast, assuming they actually work.

    But for me, I don't like it. You click one thing, and you can get two things without asking for the other. Oh look, my browser program was just updated by default to Chrome, which was installed, but I didn't ask for or want that. I'm NOT saying this is what happens, but it could.

    So now I must try APP Shop and see what it is all about. I'll install it on a Win 10 TP installation, not a great loss if it causes problems. If APP Shop is causing the problems you now have, that is a major problem that needs immediate attention.

    If APP Shop becomes the only way to get things like UEFI/BIOS updates, I'll think twice before buying ASRock again. That's not a threat, simply a reality.

    IMO, APP Shop is not what PC enthusiasts want. I'll give it a chance, but the main idea behind it is not for me.

  3. #3
    SandsOfTime is offline Member
    Join Date
    Jul 2014
    Location
    Germany
    Posts
    143

    Default Re: Z97 Extreme4 - No USB issue after update.

    Here are the USB UEFI settings of my ASRock Z97E-ITX/ac for fully working USB keyboard and mouse. Not quite your Z97 Extreme4, but nevertheless an ASRock Z97 board.

    Z97 Extreme4 - No USB issue after update.-usb-jpg
    ---
    Mind is not cumulative, but stupidity is.

  4. #4
    Britgeezer is offline Member
    Join Date
    Nov 2013
    Location
    New Jersey
    Posts
    162

    Default Re: Z97 Extreme4 - No USB issue after update.

    Yes, thanks both for the answers.

    I tried various different wired M/KB I have, no good. I even connected an older wireless Logitech that is combo USB and PS2 - nothing. I have asked my son to look around for old PS2 M/KB at work.

    I tried the patch already on or off, no difference.

    Keep in mind both work while in BIOS, just not in windows (7) during any normal or safe / restore mode. That's simply weird, especially that it will not work in W7 installation mode.

    @parsec yes we can "discuss" APP later, thankfully doesn't work with Z77-Extreme4 (my server) and like you I keep bookmarks to the download pages. However, I don't recall any issue to find the download page yesterday. APP is a good idea for some as an option I think they are trying to follow MSI live update - but implemented it poorly.

    Add to the ASR issues - sleep modes even after the latest BIOS update lots of options but hard to control. Right now out of 2 Z97- Extreme4's one will not sleep, even on when I manually put it in sleep mode and the other will sleep automatically but will wake up within seconds if I put it in sleep manually.

    For my last PC update frustrated with sleep issues, I tried an MSI Z97 Gaming 7, not 100% with sleep on that MB either... occasionally and randomly wakes up and goes back to sleep within minutes, very few options in BIOS for the sleep feature.

    Well I think I must try a CMOS reset, no other ideas until I can get a PS2 mouse.

  5. #5
    Britgeezer is offline Member
    Join Date
    Nov 2013
    Location
    New Jersey
    Posts
    162

    Default Re: Z97 Extreme4 - No USB issue after update.

    Problem fixed after lots of tinkering.

    Cleared CMOS several times, enabled default UEFI settings and left PC at start screen. After while the screen cleared and I saw an error message trouble with USB driver not properly installed. Allowed to complete, but still had ! error message in devices.

    USB 2.0 was now working so KB/M working. Reinstalled both USB 3.0 drivers and all is now well.

    Coming back to APP Shop

    I think the latest Intel USB 3.0 driver was / is funky. The 1st time I extracted the zip file I got an error message when I tried to install via setup. The 2nd time I extracted the files manually and saw a difference in number of file and all was well with the update.

    I guess APP Shop isn't smart enough or simply can't detect that and left me partially installed with new drivers that also prevented USB 2.0 working in Windows. So that proves the point auto installers can create more problems than they fix. BAD, Naughty APP Shop. PS - Its now deleted.
    Last edited by Britgeezer; 04-07-2015 at 05:43 AM.

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Extreme4 - No USB issue after update.

    Glad that worked out for you. Did you install the Intel USB 3.0 version 3.0.4.65 driver from Intel's site, this one:

    https://downloadcenter.intel.com/dow...Chipset-Family

    Or something else?

    Have you ever looked at the Intel Log files about their installation programs? There might be one for the USB 3.0 driver. Just look for an Intel folder in the root of your C: drive, there should be a Logs folder in it.

    I imagine APP Shop is just a front end, a down loader program that runs the installer after unzipping the file. But it would need information about every installation program in order to check for the correct files and their sizes. That's just more than I think we can expect from it.

    Speaking of APP Shop... I've got a different take on it now.

    I was checking up on the USB 3.0 driver in the Win 7 download list for our Z97 Extreme6 board. The last version listed is 3.0.1.41. The version on Intel's site is 3.0.4.65. Lets assume APP Shop was (trying) to install 3.0.4.65.

    Imagine a mobo manufacture constantly needing to update the driver, utility, and BIOS downloads for there boards. Each board of the same chipset (Z97, etc) uses many of the same drivers, so very redundant work that is prone to human errors. Plus ASRock is not known for updating the driver downloads of their older products. There are arguments pro and con on that subject, I can see both sides... to a degree.

    Now imagine an automated way of providing these updates for mother boards that is simpler for the manufacture to maintain and organize. It is also (seemingly) convenient to the users, they don't need to visit their board's download page, start a download, and run the installer themselves (exhausting!) Or do a scary BIOS update. Not to mention knowing what they are doing.

    Add a few "perks" to it (seriously, Chrome, for "free") and we have APP Shop. It makes everybody happier!

    But guess what, USB 3.0 driver version 3.0.4.65 is not listed in our board's download list. Our board will be one year old on 4/28, reckoning from the date of the first version of the UEFI. Downloads are already not being kept up to date... oh wait, use APP Shop!

    So... a UEFI update via APP Shop is done by... the Windows UEFI update method?!?!

    If UEFI updates will only be available through APP Shop, that my friend is a BIG mistake.

  7. #7
    Britgeezer is offline Member
    Join Date
    Nov 2013
    Location
    New Jersey
    Posts
    162

    Default Re: Z97 Extreme4 - No USB issue after update.

    Quote Originally Posted by parsec View Post
    Glad that worked out for you. Did you install the Intel USB 3.0 version 3.0.4.65 driver from Intel's site, this one:

    https://downloadcenter.intel.com/dow...Chipset-Family

    Or something else?

    Have you ever looked at the Intel Log files about their installation programs? There might be one for the USB 3.0 driver. Just look for an Intel folder in the root of your C: drive, there should be a Logs folder in it.
    Being a relatively trusting person... I downloaded the latest from ASR that's the file they posted 2/3/2015 and its USB version 3.0.1.41 so they are a tad behind with versions. I recall many years ago that Manuf didn't jump on new drivers immediately so they could verify them with their MB's maybe that was an excuse for delays.

    What do you think install the latest from intel or leave it alone now its working. PS log shows original driver was 3.0.0.16

  8. #8
    Britgeezer is offline Member
    Join Date
    Nov 2013
    Location
    New Jersey
    Posts
    162

    Default Re: Z97 Extreme4 - No USB issue after update.

    Just an update.

    Installed the Intel USB 3.0 version 3.0.4.65 and updated the INF/ ME from ASR site to be sure.

    PS any thoughts on the Beta drivers? Some look quite old.

    There is one for APP Shop there.
    Last edited by Britgeezer; 04-08-2015 at 12:17 PM.

  9. #9
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Extreme4 - No USB issue after update.

    Quote Originally Posted by Britgeezer View Post
    Just an update.

    Installed the Intel USB 3.0 version 3.0.4.65 and updated the INF/ ME from ASR site to be sure.

    PS any thoughts on the Beta drivers? Some look quite old.

    There is one for APP Shop there.
    Do you mean an APP Shop beta driver? I don't see that.

    I'd install the new USB 3.0 driver. I think the problem you had, while quite bad, was a fluke either from a damaged download or possibly APP Shop.

    I've used the Intel beta drivers in the Beta section, when I first got this board. They seemed fine IMO. Not much point in using them now, since new, official versions of all of them are available. Intel has IRST 13.6 on their download pages, and INF/Chipset 10.0.26.

    Most of the time the new versions of the INF/Chipset installer contain support for new hardware, so unless you have some of that hardware, the updates should be worthless. Of course I have run the new INF/Chipset installer, just in case, plus I don't understand every description included (OCD.)

    This is from the Release Notes for the 10.0.26 Chipset installation program:

    Z97 Extreme4 - No USB issue after update.-inf-10-0-26-release-notes-png

    If you can only read Slovak, then you might need this version. Items 7 and possibly 4 might be of significance. Or if you are using "Server Threshold x64".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •