Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: Z97 Anniversary...HDMI dont work




  1. #1
    Join Date
    Apr 2015
    Location
    Greece
    Posts
    5

    Default Z97 Anniversary...HDMI dont work

    hi...i have the Asrock z97 anniversary, and the HDMI dont work...Why???
    I search for drivers and dont find anything.
    I'ts normal that?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Anniversary...HDMI dont work

    HDMI doesn't work? Which means you don't get a video signal to your monitor, right? You are using the Intel integrated graphics, and not a video card?

    What are you using for a CPU? What monitor are you using? Do you use Windows (what version?) or something else?

    Most versions of Windows will have a built in graphics driver that will work, but you need to install the Intel graphics driver after you install Windows.

    You still should get video signal to a monitor without any driver at all, to use the BIOS.

    Your PC may not even be starting, it may seem to start since some of the fans run, but that does not mean it completed POST.

    Do you have the 4 or 8 pin CPU power cable connected to the board from the power supply?
    Last edited by parsec; 04-10-2015 at 12:43 PM.

  3. #3
    Join Date
    Apr 2015
    Location
    Greece
    Posts
    5

    Default Re: Z97 Anniversary...HDMI dont work

    HDMI doesn't work? Which means you don't get a video signal to your monitor, right? You are using the Intel integrated graphics, and not a video card?
    ''I am Using the ATI Radeon HD 2600 Pro (They dont have HDMI)''

    What are you using for a CPU? What monitor are you using? Do you use Windows (what version?) or something else?
    ''CPU Intel G3258 in Windows 7 x64''

    Most versions of Windows will have a built in graphics driver that will work, but you need to install the Intel graphics driver after you install Windows.
    ''I try to install the VGA drivers from Asrock site, and the Installation stop because they say not the right version (maybe is for the ''M'' version''

    You still should get video signal to a monitor without any driver at all, to use the BIOS.
    ''I have signal in my LG Flatron Slim monitor, but the HDMI dont work.''

    Your PC may not even be starting, it may seem to start since some of the fans run, but that does not mean it completed POST.
    Do you have the 4 or 8 pin CPU power cable connected to the board from the power supply?

    The configuration of my PC work perfect, but the HDMI dont...I dont know if they have settings from Bios.
    Anyone to test if the HDMI works in the AsRock Z97 Anniversary? (Not the M Version with Graphic Card on Board)

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Anniversary...HDMI dont work

    Quote Originally Posted by musicland View Post
    HDMI doesn't work? Which means you don't get a video signal to your monitor, right? You are using the Intel integrated graphics, and not a video card?
    ''I am Using the ATI Radeon HD 2600 Pro (They dont have HDMI)''

    What are you using for a CPU? What monitor are you using? Do you use Windows (what version?) or something else?
    ''CPU Intel G3258 in Windows 7 x64''

    Most versions of Windows will have a built in graphics driver that will work, but you need to install the Intel graphics driver after you install Windows.
    ''I try to install the VGA drivers from Asrock site, and the Installation stop because they say not the right version (maybe is for the ''M'' version''

    You still should get video signal to a monitor without any driver at all, to use the BIOS.
    ''I have signal in my LG Flatron Slim monitor, but the HDMI dont work.''

    Your PC may not even be starting, it may seem to start since some of the fans run, but that does not mean it completed POST.
    Do you have the 4 or 8 pin CPU power cable connected to the board from the power supply?

    The configuration of my PC work perfect, but the HDMI dont...I dont know if they have settings from Bios.
    Anyone to test if the HDMI works in the AsRock Z97 Anniversary? (Not the M Version with Graphic Card on Board)
    There is no difference in on board graphics between the Z97 Anniversary and the Z97M Anniversary, the graphics are part of the CPU, not a chip or card built into the board. The graphics come from the G3258 or any Intel 1150 processor that has integrated graphics.


    The ATI Radeon HD 2600 Pro cannot use the HDMI output on any mother board, that is only for the Intel integrated graphics in the CPU.

  5. #5
    Join Date
    Apr 2015
    Location
    Greece
    Posts
    5

    Default Re: Z97 Anniversary...HDMI dont work

    ok
    But what they need to work the hdmi?
    This is what i need...You know???

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Anniversary...HDMI dont work

    When you have a video card in your board, like your ATI Radeon HD 2600, and you also have a CPU that has integrated graphics like your G3258 does, you must select which one you want to use in the BIOS.

    In the BIOS, Advanced screen, find Chipset Configuration. In that screen the first option is Primary Graphics Adapter.

    When that is set to PCI Express, the board will use the ATI Radeon HD 2600.

    When that is set to Onboard, the board will use the G3258 graphics.

    If you set this to Onboard, the HDMI output should work.

    The video driver for the G3258 graphics can be downloaded here: https://downloadcenter.intel.com/dow...7-8-8-1-64-bit

    You need the win64_153618.exe file.

  7. #7
    Join Date
    Apr 2015
    Location
    Greece
    Posts
    5

    Default Re: Z97 Anniversary...HDMI dont work

    Thank you my friend...
    Last one question...Can i use my ATI with DVI out for my monitor, and the hdmi in my TV both if i select primary graphic card On Board?

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Anniversary...HDMI dont work

    Yes you should be able to do that.

    Again in the BIOS, Advanced screen, in the Chipset Configuration screen, look for IGPU Multi-Monitor. Set that to Enabled to keep the integrated graphics working when you are using a video card too.

  9. #9
    Join Date
    Apr 2015
    Location
    Greece
    Posts
    5

    Default Re: Z97 Anniversary...HDMI dont work

    Thank you my friend
    Now they work :)
    Have a nice day

  10. #10
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z97 Anniversary...HDMI dont work

    Good, glad things are working for you now. Stop by any time with questions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •