Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Asrock z97 extreme 9 + sm951 256 GB m.2




  1. #1
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Asrock z97 extreme 9 + sm951 256 GB m.2

    Hello,

    I cannot complete the win 8.1 64 installation. The m.2 disk does not appear in boot options.
    What do i have to do before destroying everything? 😳

    Thanks
    Last edited by bittoliquido; 04-20-2015 at 11:12 PM. Reason: Complete title

  2. #2
    Join Date
    Nov 2014
    Location
    Sydney, Australia
    Posts
    9

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Quote Originally Posted by bittoliquido View Post
    Hello,

    I cannot complete the win 8.1 64 installation. The m.2 disk does not appear in boot options.
    What do i have to do before destroying everything? 😳

    Thanks
    First, make sure you have the latest bios installed. Then follow our installation guide. It's for the XP941, but the process for the SM951 is exactly the same.

    Let us know how it goes.

    cheers, Rod

  3. #3
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Thanks,

    I have repeated the procedure described in your link several Times.
    After the first restart windows does not find the m.2 disk and so it restart from usb, reinstalling again the first part.

    Is there any beta bios for extreme 9 that permit to choose m.2 as booting disk?

    Thanks

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Which M.2 port are you using for your SM951?

    You must use the Ultra M.2 slot, that is just below the first/top PCIe x 16 slot.

    The Z97 Extreme6 board has a beta bios for use with the SM951. So far, your board does not have this kind of beta BIOS. Hopefully ASRock will see your thread and create one for this board. Or you can contact ASRock support directly here:

    ASRock > Support Request Form

    Did you start the System Browser tool in the BIOS, to see if the SM951 is recognized by the board? With new SSDs like this, or even standard SSDs, it may take a restart or two of the board before the SSD is recognized.

    If you configured the BIOS settings correctly when you installed Win 8.1, in the boot options you should see an entry of "Windows Boot Manager". That is how the SM951 will be identified in the boot order when correctly installed in UEFI mode.

    What boot entry are you using for the USB flash drive with Win 8.1? You must choose the entry that says, "UEFI...", whatever the name of your flash drive is.

  5. #5
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    hello,

    thanks Parsec.

    I tried both, the ultra and the normal.
    The ssd is very recognized in the bios, I can see listed in the section storage. But it does not appear in the boot menu.
    The only combination to have "windows boot manager" listed in the boot option is to choose the sata as RAID.
    I am installing from a USB selecting by f11 the uefi usb. I also tried from the exit menu load efi bios (I do not remenber the exact name, but is the last option in the exit menu).
    I also used the ripping from original win8.1 - no OEM - disk and used the ISO from Microsoft. With all the combination of no extra file in the usb root, or adding the shellx64 and/or the bootx64.

    I have installed on an old drive and then copied with the one-to-one sw to transfer from old drive to m.2 drive.

    I made all the combinations also with adding drivers in the windows formatting window, loading form CD, from USB stick with a folder created from BIOS.
    I am missing only the beta driver in the airsick beta section, but these are really out of date compared to the CD (!!!) and to the USB Stick from BIOS.
    I have the latest BIOS version and in the beta is available a really old one.

    I always get stuck after the first step of installation, where it does not find the m.2 drive as booting option. And if I choose raid windows start but it stop immediately with and system error asking to modify bios and reinstall the OS.


    I'll contact asrock - thanks for the link - to get some clarification.

    If you have any other suggestion please let me know.


    Thanks

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    A beta BIOS like the one for the Z97 Extreme6 board probably is the only way to fix the installation problem.

    The Launch EFI Shell from filesystem device option in the BIOS will not help you with this problem. That option is used to run the shellx64 program from the BIOS.

    I'm not sure if you did this, when you used RAID mode and got the Windows Boot Manager entry in the boot order, did you set the SATA mode to RAID before you started to install Windows? If you didn't, setting the SATA mode to RAID before you start the OS installation (and always use RAID mode) might help.

    Did you let the Windows installation program format the SM951? That is the best way to get it formatted correctly. It must be formatted as GPT.

  7. #7
    Join Date
    Dec 2014
    Location
    Taiwan
    Posts
    124

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Dear bittoliquido,

    I'm ASRock HQ Eddy_Huang
    Please update below link of Z97 Extreme9 BIOS L1.52, this BIOS have update Samsung SM951 compatibility.
    https://drive.google.com/file/d/0B0D...ew?usp=sharing
    We will also update and put this version BIOS on our website recently.

    If have any question, please feel free to contact us.
    ASRock TSD
    Eddy.
    Last edited by ASRock TSD-Eddy; 04-22-2015 at 10:33 AM.

  8. #8
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Quote Originally Posted by parsec View Post
    A beta BIOS like the one for the Z97 Extreme6 board probably is the only way to fix the installation problem.

    The Launch EFI Shell from filesystem device option in the BIOS will not help you with this problem. That option is used to run the shellx64 program from the BIOS.

    I'm not sure if you did this, when you used RAID mode and got the Windows Boot Manager entry in the boot order, did you set the SATA mode to RAID before you started to install Windows? If you didn't, setting the SATA mode to RAID before you start the OS installation (and always use RAID mode) might help.

    Did you let the Windows installation program format the SM951? That is the best way to get it formatted correctly. It must be formatted as GPT.
    hello,

    thanks, I did it also in that sequence, raid before the OS installation. No success. It install only the first part but at the restart windows ask to repeat the installation

    paolo

  9. #9
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Quote Originally Posted by ASRock TSD-Eddy View Post
    Dear bittoliquido,

    I'm ASRock HQ Eddy_Huang
    Please update below link of Z97 Extreme9 BIOS P1.52, we have update Samsung SM951 compatibility.
    https://drive.google.com/file/d/0B0D...ew?usp=sharing
    We will also update and put this version BIOS on our website recently.

    If have any question, please feel free to contact us.
    ASRock TSD
    Eddy.
    wow Eddy!


    I'll try asap.


    have a great day,

    paolo

  10. #10
    Join Date
    Apr 2015
    Location
    Milan
    Posts
    6

    Default Re: Asrock z97 extreme 9 + sm951 256 GB m.2

    Eddy!

    problem solved, with new bios now it works perfectly.

    The disk is listed in the storage section and windows boot manager is in the boot list.

    :-)


    thanks and congratulation to this great forum

    paolo

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •