Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: Board damaged by power supply?




  1. #1
    Kosake is offline Junior Member
    Join Date
    Jul 2014
    Location
    Germany
    Posts
    14

    Default Board damaged by power supply?

    Hi Community,

    sorry for my bad english.

    I've bought a Asrock Z97 Anniversary in August 2014. Two weeks ago the PC no longer booting. The PC Speaker said two short beep. I searched the internet but don't find the result of 2x short beep, maybe it's parity check? I don't know.

    I removed all components but CPU and RAM: no improvement
    I changed RAM: no improvement
    BIOS reset: no improvement
    A defect of the CPU is unlikely i guess.

    I sent my board to my dealer and now, after several weeks, i got a new Board. I have not yet installed....

    My question is: Is it possible, that the power supply is broken and it has destroyed my board? Or can i exclude that due to the beep code?

    I want to prevent that this happen again and i have to wait severel weeks once again.

    Thanks for your help!

    Board: Asrock Z97 Anniversary
    Power supply: beQuiet! Straight Power E8 (bought October 2011)
    CPU: i5 4690k
    Last edited by Kosake; 05-28-2015 at 01:09 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •