Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Low usb 3.0 speed before system restart?




  1. #1
    miroslav216 is offline Junior Member
    Join Date
    Jun 2015
    Location
    Rousse, Bulgaria
    Posts
    2

    Default Low usb 3.0 speed before system restart?

    Hello everybody, am Miroslav from Bulgaria.
    For the last half year I have Asrock Z97 Extreme Motherboard, until now everything was fine.
    Before two day I purchased my first usb 3.0 device - its 32 gb flash drive, model is HyperX Fury 32gb usb 3.0
    Problem is that when I plug it in some of the Intel controlled usb 3.0 port in the back of the motherboard drive operate in usb 2.0 mode, to get usb 3.0 speed working I must keep flash drive plugged in the same port and restart the computer - after restart problem get fixed until I unplug flash drive and shutdown or restart.
    I have tried three operating system and result are the same:
    1. Windows 7 64 bit with Intel extensible host controller usb 3.0 driver installed
    2. Windows 8.1 64 bit operating with native usb 3.0 driver (intel extensible host controller usb 3.0 is not needed for windows 8.1)
    3. Ubuntu 14.10

    Here is the speed when plug the flash drive for a first time in some of the four Intel usb 3.0 ports ~20write/40mb read:

    Here is the speed after restarting computer and keeping flash drive plugged in the same Intel usb 3.0 port ~ 70mb write/140mb read:


    And here the speed when usb drive is connected to some of the two ASMedia ASM1042AE controlled usb 3.0 port (here I don't have any problem even before restart speed is the same and good for usb 3.0):


    I decided to test usb with free program "usbdeview" to see what is happening.

    Here is a result from program when I plug flash drive in Intel usb 3.0 port, as you can see drive operate in usb 2.1 300mA mode:

    Here the result afrer restarting the computer and keep flash drive plugged in the same usb 3.0 port like before ,as you can see drive drive operate in usb 3.0 504mA mode:


    One more test, this time with free program "USB View".
    Here is when I plug flash drive for a first time:

    Here is after restart when keeping flash drive plugged in in the same port.


    First I decided that problem is in USB Setting from bios and started to change some of the settings.
    Here are some pictures of all usb options I have in bios:


    I tried to change Intel usb 3.0 mode to Auto, Smart Auto and Eabled without effect.
    Turning off USB Compatibility patch without any effect again. I even stopped Тhird party Usb controller but again there is no any difference.
    Disabling Legacy usb and Legacy usb 3.0 resulted in my keyboard and mouse not working in bios, but again there is no difference in USB speed.

    Am not sure is that compatibility problem, or there is some settings that must be tweaked in bios or maybe something else.

    Thanks everyone for help or suggestions and sorry for my bad English.
    Last edited by miroslav216; 06-27-2015 at 03:33 AM.

  2. #2
    Join Date
    May 2011
    Location
    Rudehen, Tehran, Iran
    Posts
    302

    Default Re: Low usb 3.0 speed before system restart?

    Hello
    Intel Flexible I/O technology decides about USB mode at boot. If you select "Enabled" for Intel usb 3.0 mode in bios and still have problem, it is a type of bios bug because it is working like "Auto".
    Have you updated to the latest bios version?

  3. #3
    miroslav216 is offline Junior Member
    Join Date
    Jun 2015
    Location
    Rousse, Bulgaria
    Posts
    2

    Default Re: Low usb 3.0 speed before system restart?

    Thanks you for the answer.
    Yes, bios is latest version from Asrock website (version 2.10),
    I changed Intel usb 3.0 mode to Enabled in bios without postive result, flash drive still work in usb 2.0 mode when is connected to one of the Intel chipset controlled usb 3.0 port in the back of the motherboard, except if I keep flash drive connected in same port and restart computer, after restart flash drive start to work in normal usb 3.0 speed.

    Restarting or shutdown computer again without flash drive inserted bring back same usb 2.0 speed in problematic Intel chipset controlled usb 3.0 ports after pc load.

    Here is screenshot from Device manager before and after restart of the computer when keeping flashdrive untouched:

    After restart device move from PORT_#0009 HUB_#0003 to PORT_#0021 HUB_#0003

    If this is BIOS bug what is the best thing to do?
    Last edited by miroslav216; 06-28-2015 at 01:18 AM.

  4. #4
    Join Date
    May 2011
    Location
    Rudehen, Tehran, Iran
    Posts
    302

    Default Re: Low usb 3.0 speed before system restart?

    Quote Originally Posted by miroslav216 View Post
    If this is BIOS bug what is the best thing to do?
    When a bug is related to bios, we have very restricted possibility to work around it.
    Until ASRock TSD-Eddy see this post and offer you the updated bios, you can buy the cheapest USB3.0 flash and leave it connected to one of USB ports. After addressing the problem by ASRock, keep it in your pocket.
    Sorry! no better soulution I could find.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •