Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock B85M-ITX USB ports die with USB3




  1. #1
    Join Date
    Sep 2015
    Location
    US
    Posts
    2

    Default ASRock B85M-ITX USB ports die with USB3

    I've just installed a new system with this board and it seems to work beautifully - until I install the Intel USB 3.0 driver, then as soon as the Windows logo pops up during boot, my mouse and any other USB devices die.

    Fortunately I have a PS2 style keyboard I could plug in. But all the USB ports are non-responsive. As soon as I uninstall the driver or disable USB3 in the BIOS, all is well again.

    I started with the Intel USB3 driver on the website and then upgraded to the latest on the Intel website, same thing.

    I've upgraded the BIOS from 2.3 to 2.4 and then back again.

    I've upgraded to the last INF from the Intel website.

    Nothing seems to work besides disabling USB3 (which I would like to have working). Any ideas?

  2. #2
    Join Date
    Sep 2015
    Location
    US
    Posts
    2

    Default Re: ASRock B85M-ITX USB ports die with USB3

    Fixed it, in case it is helpful to anyone in the future...

    After deleting the USB3 driver so I could use my mouse, I went to Device Manager. It shows the USB3 controller as unknown hardware. I told Windows to uninstall the hardware and it disappeared. Then I told Device Manager to Scan for Changes, it found the controller again and tried to look for a driver. I interrupted the process, telling it not to look at Windows Update and then canceled out of the automatic driver install process. I then manually installed the latest USB3 drivers from Intel's website. It finally installed properly and everything is working.

    Note if you don't have a PS2 keyboard to uninstall the driver, you can go into the BIOS and disable USB3. Boot and you should have your mouse, then uninstall the USB3 driver, reboot and go back to the BIOS to enable USB3 the follow the steps above in Device Manager.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •