Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asrock N3150-ITX cannot boot FreeNAS




  1. #1
    Join Date
    Oct 2015
    Location
    Spain
    Posts
    2

    Default Asrock N3150-ITX cannot boot FreeNAS

    <article>
    Hi,

    I cannot boot the FreeNAS-9.3-STABLE-201509022158 image in my NAS: Asrock N3150-ITX, 1xKingston 8GB DDR3 1600MHz PC3L-12800 SO-DIMM, latest BIOS P1.30.

    I tried two different approaches, with two different pendrives of 2 and 8 GB:

    1. I burn the .iso in an USB pendrive with Win32DiskImager. I turn on the NAS with it. I select the boot device as the USB pendrive (BIOS legacy mode), the screen becomes black and nothing happens. The GRUB menu does not appear. If I choose instead the UEFI option, then, the screen comes back to the "select boot device" screen...

    2. Then, in VirtualBox, I installed FreeNAS in the USB pendrive. Later, in another VM, I booted it up. From the GUI, I createad a loader tunable xhci_load with value set to YES. Then, when I plugged the pendrive in the NAS, and booted it up, the screen became black, nothing appeared or happened. But, if I plug it in the VM, it works perfectly, the GRUB menu appears and it starts normally.

    Just to test if the NAS could boot anything from an USB, I burned the OpenELEC-Generic.x86_64-5.95.5.img in a pendrive and it worked perfectly, both in BIOS legacy and UEFI modes.

    How could I make the FreeNAS image boot with this motherboard? What would be the proper settings in the BIOS to make it work?

    Thank you in advance.
    </article>

  2. #2
    Join Date
    Oct 2015
    Location
    Spain
    Posts
    2

    Default Re: Asrock N3150-ITX cannot boot FreeNAS

    I tried some more things:

    • FreeNAS-9.3-STABLE-201509282017 -> It does not boot up. No GRUB menu. It works perfectly in a VM (VirtualBox).
    • FreeNAS-10.2-ALPHA-201510091516-bf6797e-x64 -> It does not boot up. No GRUB menu. It works perfectly in a VM (VirtualBox).
    • gparted-live-0.23.0-1-i586 -> It boots up and works perfectly
    • memtest86-usb 6.2 -> It boots up and works perfectly. All tests were successfull.
    • FreeBSD-9.3-RELEASE-amd64-memstick.img -> It does not boot up
    • FreeBSD-10.2-STABLE-amd64-20151008-r289053-memstick.img -> It does not boot up
    • FreeBSD-10.2-STABLE-amd64-20151008-r289053-uefi-memstick.img -> It only boots up in UEFI mode.

    So, I think it is crystal clear: This N3150-ITX motherboard cannot boot up a GPT pendrive in BIOS Legacy Mode, only in UEFI.

    The thing is that I have the Compatibility Support Module (CSM) enabled and Launch PXE, Storage and Video OpROM Policies in "Legacy only", Legacy USB Support in "Enabled"...


    So, what else could I do in the UEFI settings?

    Is it a bug of this BIOS P1.30 version? Is Asrock planning to solve it in the near future?

    Thank you very much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •