Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.




  1. #1
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    I took a snap show of the problem using win7 screen capture.
    I just did a clean install of win 7 and was up dating the drivers to Intel(R)
    _USB_3.0_eXtensible_Host_Controller_Driver_4.0.0.3 6 from
    Intel(R)_USB_3.0_eXtensible_Host_Driver_3.0.5.69 (I changed the exact length cuz nero was complain its too
    long)
    Im using a z97 extreme 6 and win 7 x64 home premium. The other odd thing is it created a pop up after each
    time i boot and i dont know what it means nor how to get rid of it.
    was wondering if it could be related to order of install for ex inf, management engine etc., OR if i need to
    install the disk which is OEM win 7 service pack 1 and Should i wait to update with windows update before
    installing the drivers?
    All the updates that im aware of have been updated before install of OS.
    Thx
    P.s. had this happened on my last clean install
    and I installed from dir in drive d:
    Attached Images Attached Images "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.-capture-png 

  2. #2
    SandsOfTime is offline Member
    Join Date
    Jul 2014
    Location
    Germany
    Posts
    143

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Do you have the kernel-mode driver framework 1.11 installed? It's necessary for Windows 7 to install newer drivers.
    ---
    Mind is not cumulative, but stupidity is.

  3. #3
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Look in programs and uninstall the Intel USB 3.0 SOFT.


    Download the driver from ASrock 3.0.1.41. ASrock has a website. ASRock > Z97 Extreme6


    The newest driver out is 4.0.2.42 WHQL, but usually the one onsite is the stablest.
    Last edited by odiebugs; 11-15-2015 at 05:36 PM.

  4. #4
    SandsOfTime is offline Member
    Join Date
    Jul 2014
    Location
    Germany
    Posts
    143

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    @odiebugs:

    I have the 4.0.2.42 installed on my Z97E-ITX/ac motherboard and it' running without problems. But in my experience is is recommended to deinstall an older Intel USB 3.0 driver, reboot and then install a newer version.
    ---
    Mind is not cumulative, but stupidity is.

  5. #5
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    I installed the win 7 w/sp1 that I have then ran win update which took like an hd then tried installing usb 3 v3.0.5.69 off intel site and still had same issue.

  6. #6
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Quote Originally Posted by odiebugs View Post
    Look in programs and uninstall the Intel USB 3.0 SOFT.


    Download the driver from ASrock 3.0.1.41. ASrock has a website. ASRock > Z97 Extreme6


    The newest driver out is 4.0.2.42 WHQL, but usually the one onsite is the stablest.
    yeah agree 100% its why I went with v 3.0.1.41 and what I don't get it still deletes old drivers one by one and creates new ones its just the other crap that happens like I describe.

  7. #7
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    I also looked in win update history and I don't see it there. I just don't get why INTC USB 3 are such a pain nothing else is and I did install INF first.

  8. #8
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Quote Originally Posted by SandsOfTime View Post
    Do you have the kernel-mode driver framework 1.11 installed? It's necessary for Windows 7 to install newer drivers.
    Do you have any ideas as to why win update did not install it, i just dont get why intel driver for usb 3 is such a pain in the but

  9. #9
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Quote Originally Posted by SandsOfTime View Post
    Do you have the kernel-mode driver framework 1.11 installed? It's necessary for Windows 7 to install newer drivers.
    when i went to install it it said its already on my system

  10. #10
    sebastian869 is offline Junior Member
    Join Date
    Aug 2014
    Location
    NYC
    Posts
    69

    Default Re: "Drv64.exe - bad image" when i went to install win 7 USB 3 drivers.

    Quote Originally Posted by sebastian869 View Post
    Do you have any ideas as to why win update did not install it, i just dont get why intel driver for usb 3 is such a pain in the but
    What is the best spot to install from for ex? DVD sept HD? or on c?

    THX

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •