Hi all, I had a Fatality Gen3 motherboard with a i7 2700K processor and PC12800 (G.Skill Ripjaws) which all worked fine until the mobo died.

I bought a Z75 Pro3 board to replace it and used the same processor and memory. I was getting only black screens without any beeps, which could mean memory or CPU.
I removed everything but the CPU and memory and started testing the modules. I was able to get in the bios once, after configuring to use the XMP profile, saving and rebooting, the screen was black again without beeps.
After trying again without success, I reset the CMOS. After that I started getting 5 beeps on boot (which means no video card). I cleared the CMOS again, changed the modules and still 5 beeps.
I put a video card and connected the monitor to it and now I can get into the bios again.

Now I have the following problems.
1) The bios detects my memory as 1333 MHz. It doesn't let me choose 1600 Mhz anymore, nor it shows the option to choose the XMP profile
2) If I connect all 4 modules, the computer boots, but only 2 modules are active. (All 4 modules work individually)
3) The onboard video doesn't work anymore, even the option in the bios is gone. Now I only have PCIe or PCI.

I tried reinstalling the UEFI using a USB drive but it didn't change anything.

Can anyone shed some light on what could be happening?