Dear Community,

I'm starting to be out of hope for my problems. I summarise: after having tons of BSOD on a new build. I reformated the Computer and now I have all imaginable issues: BSOD, freezes and Windows update don't want to get installed.


Here for the details:

Let's do things chronologically:


1. my old Mobo and CPU went dead.

2. bought a AsRock 970 Fatal1ty, FX8350, Samsung SSD 850EVO 256GB, Sapphire R9 380 4GB, and Asus Wifi 56AC. Kept my old Ram (Corsair CMX DDR3 1600mhz), old Power Supply (Corsair CX Bronze 750W, not sure on the model, but it is a 750W and Corsair) and old HDD (don't remember the model)

3. Install a fresh Windows 7 SP1 home. ALL FINE!

4. Install Windows 10. ALL FINE.

5. After a few weeks I started having BSOD, specially on Youtube. Those BSOD were having various reasons (KMODE EXCEPTION NOT HANDLED, SYSTEM SERVICE EXCEPTION, IRQL NOT LESS OR EQUAL).

6. The Minidump where providing issues on various files: TCPIP.SYS, WIN32KFULL.SYS, NTOSKRNL.EXE

7. Did everything I could to find the reason: ran sfc scannow, ran Memtest, tried to put my old 3D Card inside (that was perfectly working --> ASUS 5870 HD 1GB). Tried to see if the ASUS Wifi card was responsible. Even with that unplugged I had problems. All drivers and BIOS up to date.

8. I even started having general freezes. Even while doing nothing at all when computer was iddle.

9. Thought Windows 10 might be responsible.

10. Formatted my SSD. Installed clean Windows 7 (from Microsoft CD).

11. First thing: install AsRock Drivers. All fine.

12. Installed the latest 17.12.2015 AMD drivers for the Graphic card... two times BSOD... After several tries I get to install the drivers

13. Updating the Bios: .NET issues, MOM.EXE issues popping. Bios updated nevertheless.

14. Run Driver Booster, all drivers up to date... Still .NET issues and so on

15. Windows updates don't want to get installed...


16. Fed-up... I reformat the SSD, reinstall W7

17. Before doing anything: Tried installing the Drivers from AsRock CD --> BSOD while installing the Ethernet drivers!!!!! That before doing ANYTHING. Not even IE11 was updated.

18. Nevertheless, computer restarted and all drivers seemed to be installed.

19. Didn't install ANY Other driver. Didn't update the BIOS. I just want to get all Windows Updates. And yet I don't get them, they don't want to get installed...



I'm lost... I'm thinking about returning the MOBO to AsRock... Obviously if you have a clue I would be so grateful.

If you want my opinion, I believe the MOBO is not fine since I'm having troubles both on the Graphic Card side (MOM.EXE, BSOD on driver installation) and from Ethernet and WiFi card side (--> BSOD on installation of drivers, TCPIP.SYS BSOD) .

To recall, even by switching the Graphic card I have issues and even when using Ethernet cable only or WiFi only I have issues...


Thank you A LOT for you help.