Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock Z97 Fatality Extreme and Powercolor R9 390 GPU




  1. #1
    Taz1 is offline Junior Member
    Join Date
    Jan 2016
    Location
    PA
    Posts
    2

    Default ASRock Z97 Fatality Killer and Powercolor R9 390 GPU

    Hello everyone,
    I need some help with the new build.

    Build:
    CPU-i7 4790K
    MOBO: ASRock z97 Fatality Killer
    CPU Cooler: Antec KUHLER H2O 950 Liquid CPU Cooler
    Ram: 16GB Kingston HyperX
    PSU: Seasonic 620W 80+ Bronze
    HDD:256 SSD
    HDD: 512SSD
    OS: Win 10 64bit.
    MONITOR: LG 29" 2560x1600


    I am having issues with no signal to the monitor when connected via GPU.. The connection is via HDMI.
    I used both PCI- slots and nothing. MOBO doesn't see the GPU.
    Reinstalled OS and cleared all drivers and no go.
    Installed new ASRock drivers and no go.
    Tried downloading AMD Cystalyst software and would not finish installing.
    The Fans on the GPU spin when connected to power.
    When monitor is connected to the MOBO via HDMI, the monitor works perfectly and OS boots with no issues.

    I am going to swap graphics cards with another PC that I recently build which has Radeon R9 280x and Asus gamers MOBO. Will post update later.

    Thank you for your Help.
    Last edited by Taz1; 01-06-2016 at 09:38 PM.

  2. #2
    Taz1 is offline Junior Member
    Join Date
    Jan 2016
    Location
    PA
    Posts
    2

    Default Re: ASRock Z97 Fatality Killer and Powercolor R9 390 GPU

    Quote Originally Posted by Taz1 View Post
    Hello everyone,
    I need some help with the new build.

    Build:
    CPU-i7 4790K
    MOBO: ASRock z97 Fatality Killer
    CPU Cooler: Antec KUHLER H2O 950 Liquid CPU Cooler
    Ram: 16GB Kingston HyperX
    PSU: Seasonic 620W 80+ Bronze
    HDD:256 SSD
    HDD: 512SSD
    OS: Win 10 64bit.
    MONITOR: LG 29" 2560x1600


    I am having issues with no signal to the monitor when connected via GPU.. The connection is via HDMI.
    I used both PCI- slots and nothing. MOBO doesn't see the GPU.
    Reinstalled OS and cleared all drivers and no go.
    Installed new ASRock drivers and no go.
    Tried downloading AMD Cystalyst software and would not finish installing.
    The Fans on the GPU spin when connected to power.
    When monitor is connected to the MOBO via HDMI, the monitor works perfectly and OS boots with no issues.

    I am going to swap graphics cards with another PC that I recently build which has Radeon R9 280x and Asus gamers MOBO. Will post update later.

    Thank you for your Help.
    Found out accidentally that there is small BIOS switch on the 390 that was in the center. It didn't make any sense that it was in the center when there were two choices(SW2 and SW3). So, I put it on SW2 and it worked. The card and the MOBO are now working with no issues.
    Attached Images Attached Images ASRock Z97 Fatality Extreme and Powercolor R9 390 GPU-biosswitch-jpg 

  3. #3
    Joe-912's Avatar
    Joe-912 is offline Member
    Join Date
    Feb 2013
    Location
    UK
    Posts
    197

    Default Re: ASRock Z97 Fatality Killer and Powercolor R9 390 GPU

    Quote Originally Posted by Taz1 View Post
    Found out accidentally that there is small BIOS switch on the 390 that was in the center. It didn't make any sense that it was in the center when there were two choices(SW2 and SW3). So, I put it on SW2 and it worked. The card and the MOBO are now working with no issues.
    Yes that switch looks very easy to slide by mistake when installing hey, bet it catches more prople out hey!
    well done for posting
    Asus Maximus 7 Hero > Corsair Obsidian 750d Airflow > Intel 4790K > Noctua NH-D15 > 16GB G-skill Sniper 2133 > Samsung SM951 256GB > Sandisk X400 512GB > Western digital black Sata 6 500GB > Western digital black 640GB > Windows 10 Pro 64 > Asus 27" MX279H Monitor > Gibabyte GTX 980Ti extreme

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •