Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Asrock X58 extreme - not powering up




  1. #1
    Join Date
    Oct 2013
    Location
    Bulgaria
    Posts
    11

    Default Asrock X58 extreme - not powering up

    Hello folks!

    Recently my rig with Asrock X58 Extreme stopped powering on. The first thing I suggest was the PSU or the case power switch - so I took 100% working PSU from the other PC I have ( Cooler Master Silent Pro M600), disconnected all the peripherals hardware from the Mobo ( HDD, DVDRW, VGA, removed all the RAM, disconected all the front panels, audio, USB plugs) - the only thing remain is the Mobo with the 24Pin power cable plugged + 2x4 power CPU supply plugged. Pressed the Power buton on the Mobo ( Asrock X58 Extreme has power and reset button onboard) and nothing again. The thing that i noticed is - when i unplug the power cable ( or change the power swith on the PSU from 1 to 0 ) and plug it again - the CPU fan and the PSU fan starts for about 5-6 seconds alone - without I even press anything - and after that they stops and the Mobo don't want to power at all. Removed the Mobo from the case (suggested that maybe the case short circuit something on the Mobo) - set again only the power cables needed to the Mobo - the same situation. The last thing i noticed is when the RAM is removed and speaker is connected to the Mobo - when I plug the power cable and the Mobo powers on alone for the 5-6 seconds before it dies - there are the 3 beeps for missing RAM - and just after that the Mobo dies and dont wont to power on. Tried to connect only 20 pin power cable to the Mobo + 2x4 CPU power, tried 24 pin + 4 pin CPU power, tried 20 pin + 4 pin - all the same results. Can you guys give me some advice, or you think the Mobo is dead - just like my thoughts ?

  2. #2
    Joe-912's Avatar
    Joe-912 is offline Member
    Join Date
    Feb 2013
    Location
    UK
    Posts
    197

    Default Re: Asrock X58 extreme - not powering up

    Hi there, I would first try and change the cmos battery with a brand new one, this in the past caused my brothers old rig to not power on.
    Try replacing cmos battery first then list all you spec in more detail and your get more people helping possibly
    let us know how you get on...
    joe
    Asus Maximus 7 Hero > Corsair Obsidian 750d Airflow > Intel 4790K > Noctua NH-D15 > 16GB G-skill Sniper 2133 > Samsung SM951 256GB > Sandisk X400 512GB > Western digital black Sata 6 500GB > Western digital black 640GB > Windows 10 Pro 64 > Asus 27" MX279H Monitor > Gibabyte GTX 980Ti extreme

  3. #3
    Join Date
    Oct 2013
    Location
    Bulgaria
    Posts
    11

    Default Re: Asrock X58 extreme - not powering up

    Thanks for the advise Joe :) Today tried new 3V cmos battery, with the same result :(
    My specs are :

    Mobo: Asrock x58 Extreme
    CPU : Intel i7-950 LGA 1366 ( not OCed, at stock voltages and frequencies)
    RAM: 3x4GB Kingston 1333MHz
    PSU : Cooler Master GX 650 ( as I posted earlier, I tried the Mobo with my other PSU aswell - Cooler Master Silent Pro M600)
    HDD : Seagate Barracuda 3TB SATA3
    VGA: Radeon Sapphire HD 7850 OC 2GB
    Case : Cooler Master SILENCIO 550 SILENT BLACK

    Thanks again to everyone, who will try to help me bring my Mobo back to life :)
    Last edited by Samail; 01-13-2016 at 12:40 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •