Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue




  1. #1
    Join Date
    Jan 2016
    Location
    United States
    Posts
    9

    Exclamation Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    I have followed steps to create RAID1 via UEFI setup:


    Change SATA to RAID
    CSM -> Storeage OpRom Policy -> UEFI only
    Advanced -> Intel Rapid Storage Technology -> created RAID1 volume and left SSD as non-RAID


    but when I go to the Boot menu and Boot Options I'm not able to setup SSD or RAID1 as bootable device (are not on the drop down list) so at that point Windows OS cannot be installed on any of those drive setups.


    I have tried multiple times and cannot get any disk in the Boot Options menu when CSM switched from Legacy to UEFI. For me it looks like BIOS bug. Running BIOS 2.50


    Any clue what is going on?

  2. #2
    Endlesspath's Avatar
    Endlesspath is offline Junior Member
    Join Date
    Dec 2014
    Location
    Kentucky, U.S.
    Posts
    9

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    After you download/review the pdf format of ASRocks most recent RAID manual for the ASRock Z97 Extreme6, please post specifics such as what RAID driver you installed (presumably from a FAT32 formatted USB Key setup for UEFI installs), along with which OS you are installing, etc.

    ASRock website for ASRock Z97 Extreme6 RAID manual in PDF format: ASRock > Z97 Extreme6

  3. #3
    Join Date
    Jan 2016
    Location
    United States
    Posts
    9

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    RAID drivers or OS has nothing to do in this case as I'm talking about Boot Options in the UEFI BIOS

  4. #4
    Endlesspath's Avatar
    Endlesspath is offline Junior Member
    Join Date
    Dec 2014
    Location
    Kentucky, U.S.
    Posts
    9

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    Quote Originally Posted by JackTheKnife View Post
    RAID drivers or OS has nothing to do in this case as I'm talking about Boot Options in the UEFI BIOS
    Did you even look at the pdf?..................... You have the EUFI setup properly; what your problem is, presumably you do not have a EUFI enabled USB bootable Key or CD/DVD. You need to have a EUFI bootable USB Key or CD/DVD showing in your boot options, for you to even be able to install your os. BTW, if you have a EUFI bootable USB key, and on the install screen you do not see your RAID array, it is because you haven't loaded the RAID DRIVER YET via that choice screen. Creating a EUFI bootable USB Key or CD/DVD: Create UEFI Bootable USB Of Windows 10 How to setup for RAID install of OS: How to: Set up RAID Please let me know if this clarifies anything
    Last edited by Endlesspath; 01-18-2016 at 04:25 PM. Reason: additional references

  5. #5
    Join Date
    Jan 2016
    Location
    United States
    Posts
    9

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    Quote Originally Posted by Endlesspath View Post
    Did you even look at the pdf?.....................
    Did you even read carefully my OP?

    Yes - I have followed steps [from the manual] to create RAID via UEFI setup. And yes - I have bootable USB stick with drivers on it but it doesn't matter when I need to select in the Boot menu of the UEFI BIOS which SSD or HDD is going to be system drive (boot disk) when any of those drivers are not there. And I'm still talking about BIOS Boot options not Windows or other OS boot/installation steps (BTW. Windows 7 installation process will tell you that OS cannot be installed in that case as there are not boot disk selected in the BIOS).

  6. #6
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    If your GPU or IGPU has GOP support then you can install in pure UEFI, which will drop the RAID ROM in the UEFI and switch to the EFI Sata driver in the BIOS/UEFI.

    If you have windows installed correctly on a fat32 flash drive and you open the boot menu at post and choose UEFI ( your flash drive ) just install.

    Do not worry about setting the boot menu in the UEFI because you won't get the drive letter, you get windows boot MGR, so stop looking for the setting.

    Unplug any drive but the drives you want for RAID, go into the UEFI and set the RAID array up, now exit and install windows, that's it.

    Just make sure UEFI is set to RAID and not AHCI . Now after windows is installed you can plug in the other drives.

  7. #7
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    There are two boot menu's.

    The boot inside of the UEFI/BOIS.

    There is the BIOS/UEFI POST menu that shows when you hit F11, this is where you pick UEFI ( flash drive ) if you don't see the UEFI ( your flash drive ) then it's not installed correctly on the flash drive.

    The boot menu inside the BIOS/UEFI, just ignore and install windows.

  8. #8
    Join Date
    Jan 2016
    Location
    United States
    Posts
    9

    Thumbs down Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    OK - I have loaded Windows7 installation from USB boot (F11) and then on the screen where are disks choices where to install it (RAID driver loaded) I can see SSD non-RAID disk (where I want to install OS) and RAID1 volume but choosing any of those disks it throws a message:

    Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu.

    You have said I don't need to worry about setting up boot options (disks choices) in the UEFI.

    Any clue?

  9. #9
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    When you open the POST menu and you see your flash drive, and you will see UEFI ( your flash drive ) you pick UEFI, this is the only way to install windows in UEFI.

    I don't understand what you mean choose disk where to install, because after you choose the UEFI ( your flash drive ) windows should load and start to install, you won't see where to install windows until you get to the drive screen, you know, where you make a new size, and you tell windows to install to C:.

    Do you have your HDD installed in the Sata0 Sata1 and Sata2, this is where they need to be for OS.

    Take a quick look at this - make sure you are doing the same. UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Help Forums

  10. #10
    Join Date
    Jan 2016
    Location
    United States
    Posts
    9

    Default Re: Z97 Extreme6 and RAID1 on 3TB disks UEFI issue

    Quote Originally Posted by odiebugs View Post
    Take a quick look at this - make sure you are doing the same. UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Help Forums
    I have that message on a step #8 from that tutorial above.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •