Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Corrupted Management Engine Causing Missing Overclock Options?




  1. #1
    Join Date
    Dec 2011
    Location
    US
    Posts
    3

    Default Corrupted Management Engine Causing Missing Overclock Options?

    Recently, I upgraded from 8GB (2x4GB) 1866MHz RAM to 16GB (2x8GB) 2133MHz. At some point during the process of testing different memory timings and voltages on this new RAM, memory speeds above 1333, CPU ratios above 37, XMP, and a few other less important settings disappeared from the BIOS/UEFI. In the case of CPU Ratio, the Per Core setting (not that I ever used it) is gone, and setting All Core to anything over 37 reverts to 37 (I had been using 45 for years, so I know this wasn't previously a problem). XMP is gone and the only available DRAM Frequencies are 1066 and 1333 (previously, I was using 2133).

    I've read elsewhere from people with similar issues that this is supposedly caused by the Intel Management Engine that's embedded (or whatever) in the BIOS/UEFI becoming corrupted, but don't know if this is the case.

    I've tried flashing all previous BIOS versions for my motherboard back to 1.30 (starting at L2.31A, which is what I had been using all along), and replacing the old RAM. None of which changed anything. I've contacted ASRock technical support, but they're clueless. I seem to be far more technically proficient than they are.

    What can I do to fix this? I've already ordered a new BIOS chip, but I'd like to know what caused the problem to begin with and/or how to fix it so that this doesn't happen again.

    Motherboard: ASRock Extreme3 Gen3
    CPU: Intel Core i5 2500K
    RAM: G.Skill 8GB (2x4GB) 1866MHz/G.Skill 16GB (2x8GB) 2133MHz
    Video Card: Sapphire Vapor-X R9 290
    Sound Card: Creative X-Fi Titanium
    HD: Samsung 850 Pro 256GB SSD
    OS: Microsoft Windows 10 x64
    Last edited by Akumajou; 06-02-2016 at 02:13 PM.

  2. #2
    izrailsky is offline Junior Member
    Join Date
    Jun 2016
    Location
    Russia
    Posts
    8

    Default Re: Corrupted Management Engine Causing Missing Overclock Options?

    I had similar trouble when updated bios for my AsRock p67 extreme 4. Old version was not able to recognise my r9 380. Only one available BIOS version was 3.1 so i flashed it. After that i ve investigated that i cant set ram frequency higher than 1333 mhz and my cpu ratio is also locked( but auto cpu presets were working fine) After reading all thread about my motherboard i realised last versions of BIOS that add ivy bridge support goes for B3 stepping, not B2 that i have. P67 chipset supports Intel ME v7 and v8, but B2 stepping supports Intel ME v7 only. Try to check which version of ME you have. You can do this using MEINFO utility( Google it). Problem with ME - ME bios region is locked,so you cant roll back. After flashing an old bios version i was just unable to boot cause of "HECI error".I tried flashing using DOS flash and it killed bios completely so i used a hardware programmer and now it works.
    Aslo i had this issue on z77 asus board - no turbo ratio multiplers and ram working on 1333 only. On Asus board i was able to reflash IME using FTK DOS utility and it solved all the problems.
    P.S sorry for my mistakes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •