Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: C2750D4I incorrect sensors after BIOS/BMC update




  1. #1
    desaster is offline Junior Member
    Join Date
    Jun 2015
    Location
    Finland
    Posts
    5

    Question C2750D4I incorrect sensors after BIOS/BMC update

    Hi!

    I've just upgraded the BIOS and BMC on my C2750D4I to the latest versions (BIOS 2.90, BMC 00.27.00).After the upgrade, I noticed that the sensors reported by the IPMI have changed.


    • CPU Temperature is completely missing
    • Fan sensors seem to have changed around, and there seem to be some extra fan sensors that don't exist on the actual board
    • There are now CPU_BSP1 and CPU_AP1, but they are reporting 0C



    Also, it seems the Smart Fan Control is no longer working properly, since my fans are always running at full speed.

    Here is the sensor view from the BMC web interface:



    In BIOS, the sensor readings seem to be correct (notice the difference in FAN sensors, and the existence of CPU Temperature)



    My question is, is this an issue with the BMC update? Is this a known issue? Can the BMC firmware safely be downgraded to earlier version, and will this fix the issue?
    Last edited by desaster; 07-18-2016 at 04:30 AM. Reason: try to fix formatting by using HTML

  2. #2
    desaster is offline Junior Member
    Join Date
    Jun 2015
    Location
    Finland
    Posts
    5

    Default Re: C2750D4I incorrect sensors after BIOS/BMC update

    I was eager to fix this problem, so I went ahead and downgraded both the BIOS and the BMC firmware.

    Things are now back to normal, and SmartFan is keeping the fans quiet again.


  3. #3
    karl-C2750 is offline Junior Member
    Join Date
    Aug 2016
    Location
    UK
    Posts
    7

    Default Re: C2750D4I incorrect sensors after BIOS/BMC update

    What version of the BIOS/BMC did you downgrade to?

  4. #4
    desaster is offline Junior Member
    Join Date
    Jun 2015
    Location
    Finland
    Posts
    5

    Default Re: C2750D4I incorrect sensors after BIOS/BMC update

    Quote Originally Posted by karl-C2750 View Post
    What version of the BIOS/BMC did you downgrade to?
    I downgraded to the previous versions available on the website:

    BIOS 2.80, BMC 00.23.00

    ASRock Rack > C2750D4I

  5. #5
    karl-C2750 is offline Junior Member
    Join Date
    Aug 2016
    Location
    UK
    Posts
    7

    Default Re: C2750D4I incorrect sensors after BIOS/BMC update

    Quote Originally Posted by desaster View Post
    I downgraded to the previous versions available on the website:

    BIOS 2.80, BMC 00.23.00

    ASRock Rack > C2750D4I
    Thanks, wanted to see if it could help with an issue I had, sadly not

  6. #6
    Join Date
    Mar 2017
    Location
    Orion Nebula
    Posts
    1

    Default Re: C2750D4I incorrect sensors after BIOS/BMC update

    Quote Originally Posted by desaster View Post
    I downgraded to the previous versions available on the website:

    BIOS 2.80, BMC 00.23.00

    ASRock Rack > C2750D4I
    BMC .27 and .30 are the issue, not BIOS 2.9. Anyone utilizing Smart Fan control must use BMC .23, and due to the critical watchdog timer issue in <.30, watchdog timer needs to be disabled (it's at the bottom of HW monitoring, below the fan options.
    • There's a fatal flaw in BMC <.30, and upon the watchdog timer filling flash storage, it will result in a motherboard that will not POST or boot, with the only fix being an RMA.


    Due to this critical flaw, all C2550D4I/C2750D4I owners should contact AsRock Rack and inform them BMC .27 & BMC .30 eliminate Smart Fan capabilities

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •