Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Memory Slot Issue - Fatal1ty Z170 Gaming-ITX/ac




  1. #1
    ruoccop is offline Junior Member
    Join Date
    Aug 2016
    Location
    Atlanta
    Posts
    1

    Default Memory Slot Issue - Fatal1ty Z170 Gaming-ITX/ac

    Hello all,
    This is my first build –

    using the 'ASRock Fatal1ty Z170 Gaming-ITX/ac Mini ITX LGA1151' motherboard and having a strange problem:

    When I add the memory to both slots, try and boot up – blank screen.

    If I put one of the memory modules in the slot nearest the CPU – blank screen
    If I put one in the slot furthest away from the CPU – the BIOS will come up.

    I tried this with both memory modules - so I assume that both the memory sticks are good.
    I have tried this with three different types of memory (and seated them correctly) and exactly the same problem each time.

    The memory I used was:
    2x16 Patriot Viper - which I know is not on the hardware list
    2x8 Corsair LPD 3000
    2x8 Corsair LPD 2666 (which some users have used on PCPartpicker with the same mobo)

    CPU (I assume) is okay since with one slot, I managed to get to the ‘install windows’ screens from my optical drive (feel free to correct me if my logic is incorrect).

    Is it safe to deduce that the motherboard needs replacing?

    Or is there something else I should try?

    Thanks for helping!

  2. #2
    Join Date
    Dec 2014
    Location
    Taiwan
    Posts
    124

    Default Re: Memory Slot Issue - Fatal1ty Z170 Gaming-ITX/ac

    Quote Originally Posted by ruoccop View Post
    Hello all,
    This is my first build –

    using the 'ASRock Fatal1ty Z170 Gaming-ITX/ac Mini ITX LGA1151' motherboard and having a strange problem:

    When I add the memory to both slots, try and boot up – blank screen.

    If I put one of the memory modules in the slot nearest the CPU – blank screen
    If I put one in the slot furthest away from the CPU – the BIOS will come up.

    I tried this with both memory modules - so I assume that both the memory sticks are good.
    I have tried this with three different types of memory (and seated them correctly) and exactly the same problem each time.

    The memory I used was:
    2x16 Patriot Viper - which I know is not on the hardware list
    2x8 Corsair LPD 3000
    2x8 Corsair LPD 2666 (which some users have used on PCPartpicker with the same mobo)

    CPU (I assume) is okay since with one slot, I managed to get to the ‘install windows’ screens from my optical drive (feel free to correct me if my logic is incorrect).

    Is it safe to deduce that the motherboard needs replacing?

    Or is there something else I should try?

    Thanks for helping!
    Dear ruoccop,

    We provide few suggestion for verify:
    (1)Please refer user manual page remove power core and use jumper to clear CMOS and use BIOS default setting for try.
    http://asrock.pc.cdn.bitgravity.com/...ming-ITXac.pdf
    (2)Due to memory controller is built in CPU, please kindly remove refer user manual remove CPU and check whether CPU socket pin bent or not.
    (3)If it is possible, please kindly test with another CPU for verify.

    If the problem still remains, due to warranty policy and RMA service are different by countries,it's handled by local distributor.
    For your case we suggest contact local distributor for further physical check.
    ASRock > Where to buy

    Thanks for your reply.

    ASRock TSD
    Eddy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •