Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: asrock fatality h170 performance red light on bios and not monitor output no beeps




  1. #1
    bobghw is offline Junior Member
    Join Date
    Sep 2016
    Location
    nz
    Posts
    3

    Default asrock fatality h170 performance red light on bios and not monitor output no beeps

    I built a new pc apart from case and power supply.

    Intel Core i5-6600K 3.5 GHz, Socket 1151, Skylake-S
    Asrock Fatal1ty H170 Performance Motherboard, Socket 1151, Intel H170, ATX
    Seagate FireCuda SSHD ST1000DX002 Hard Drive, 1TB, SATA 6 Gb/s
    16GB DDR4-2133MHz CL15 Non ECC
    Samsung 850 Evo Series MZ-75E250BW SSD, 250GB, 2.5", SATA 6 Gb/s
    Gigabyte Radeon R9 380X, GV-R938XG1 Gaming-4GB, Video Graphics Card, 4GB GDDR5
    Be Quiet dark rock 3

    When i booted up first time everything lights up fans go but no monitor feed no beeps and red light on bios 1.
    Last edited by bobghw; 09-24-2016 at 03:19 PM.

  2. #2
    bobghw is offline Junior Member
    Join Date
    Sep 2016
    Location
    nz
    Posts
    3

    Default Re: asrock fatality h170 performance red light on bios and not monitor output no beeps

    One of my ram sticks was not seated properly, once I sorted that and booted I got option to do eufi setup or continue,

    I changed boot order to start with usb as have downloaded windows 10 from microsoft using their tool to usb.

    but when I reboot I just get the windows 10 logo 4 blue squares and then the pc restarts??

    When I go back into bios, boot priority has reverted to ssd and yes I did save changes.

  3. #3
    bobghw is offline Junior Member
    Join Date
    Sep 2016
    Location
    nz
    Posts
    3

    Default Re: asrock fatality h170 performance red light on bios and not monitor output no beeps

    Tried using dvd with windows 10 set boot priority to optical drive and still the same windows logo for 30 seconds and the restart and nothing.

    Seriously regret buying asrock mboard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •