Ill give as much info as i can right off the bat.

asrock 880g pro3 mobo
amd phenom x6 1100t cpu
corsair xms3x2 4g ddr3
1tb seegate main drive
3x hitachi 1tb drives (storage)
crappy radeon video card(not sure what model i forgot, lowest windows score on my pc, just a vented sink. HIS? no fan)
Running ubuntu 16.04 for 2/3 weeks

Today started off great! woke up early hopped on my pc for some fun. first thing i did was to get a program to check my hardware temps. got a program to see my hardware temps through terminal. i rebooted and tested with no problem. then I changed my oc settings in bios from auto to 30% boost to see what it would do on my new os. everything was fine. played eve online through wine and watched netflix on chrome simultaneously for a few hours with a close eye on temps. havent made any adjustments in a while but last time i changed oc settings temps were higher. (was impressed with temps around 36-42c) after a few hours of fun and plenty of reboots i put my pc in sleep mode and went to do a job. a few hours went by and i come back home to awaken the beast. when i went to wake my pc from standby i got no hdmi feed. reset a few times and still same problem. poped my cover off and saw the led display E8. no boot cant access bios. did a little research and saw a link to ram. checked my chips for mounting issues and saw no problem. mabee the jiggle test will work? nope new code 54 still no boot/bios. did more research tried with one card only. no go. tried all combos with the same result. did more research and thought it might be a cpu problem. tried with cards out to see if i get same code... nope new code 19. i reinstall cards and still same code 19 not 54? so i have my hardware reinstalled in original positions when the problem started and same code 19. tried cmos to reset to factory settings and still no progress. im a novice to riggs like this first serious pc and im new to linux hopefully i didn't nuke my computer. . have been running ubuntu 16.04 for a couple weeks now. had an expired/pirated version of windows 7 that i formatted and replaced with ubuntu, and formatted my other drives for storage. updated bios from p1.30 to p1.40 before install. i have no clue where to go from this point and dont know if its a hardware/software problem.