Just received this MB in replacement of another that went bad. It is exhibiting the same issue. When you go to turn it on, the are LED (power and on the RAM (it had leds)) lights up for less than a second. The CPU, GPU, P/S Fans all spin for a second. Then, it turns off. It has never POSTed once. I tried everything (have been building systems for over 20 years) I can't get this board to do anything. I do not have another spare 1150 CPU sitting around, so, that is the only thing I haven't tried. I tried: swapping the P/S, taking out the ram so there is only one stick, unplugging everything except the CPU and GPU. Breadboarded the system, Tried even without the GPU (even though it's XEON with no graphics) No matter what I try, it is the same results. I have of course also tried CMOS reset, on BOTH bios chips. No dice. Everything just leads to powerup for less than a second with the led flashing then power off. Is there anything else you might think of that I can try, or is this MB DOA? Is there a way to rule out the CPU? Even though it is a XEON that is less than a year old, that is the only thing that has remained constant between switching MBs. The other MB was a repaired Gigabyte board, so that one not working isn't all that surprising. I have gone with ASRock boards ever since having issues with a few Gigabyte boards, and this is the first issue I've encountered.

XEON 1231
Nvidia 750ti
Crucial Ballistic 4X4GB
Corsair P/S