Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Asrock X99 Extreme11 reports only 48GB instead of 64 GB




  1. #1
    lmax25 is offline Junior Member
    Join Date
    May 2017
    Location
    Romania
    Posts
    4

    Unhappy Asrock X99 Extreme11 reports only 48GB instead of 64 GB

    Hello !
    My new Asrock X99 Extreme11 MB reports only 48GB of RAM instead of 64GB of RAM.
    I have Bios version 3.20.
    I installed HyperX Savage Black 64GB DDR4 2400MHz CL14 Quad Channel Kit
    manufacturer code : HX424C14SBK4/64 and
    CPU Intel® Core™ i7-6850K, 3.60GHz , Broadwell, 15MB, Socket 2011-V3

    Please tell me how to configure the RAM from BIOS to use all 64 GB of RAM installed.

    Thank You !

  2. #2
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Asrock X99 Extreme11 reports only 48GB instead of 64 GB

    Start by checking the system browser in the UEFI, there's a pic of your mobo and it shows the hardware connected, look to see which stick is not shown. Under TOOLS.

    For quad it's A1, B1, C1, D1, number the sticks, try each one individually in slot A1, if they all report, then put them back in same way and see, if not try switching them around.

  3. #3
    lmax25 is offline Junior Member
    Join Date
    May 2017
    Location
    Romania
    Posts
    4

    Default Re: Asrock X99 Extreme11 reports only 48GB instead of 64 GB

    As I said, all of the 4 RAM modules are shown in the SYETEM EXPLORER. A1,B1,C1,D1 slots have the same values, so all 4 modules are ok. But only 3 (except D1 slot) are usable for BIOS and WINDOWS.

    Here are some screen captures for better understanding :

    WeTransfer

  4. #4
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Asrock X99 Extreme11 reports only 48GB instead of 64 GB

    Quote Originally Posted by lmax25 View Post
    Hello !
    My new Asrock X99 Extreme11 MB reports only 48GB of RAM instead of 64GB of RAM.
    I have Bios version 3.20.
    I installed HyperX Savage Black 64GB DDR4 2400MHz CL14 Quad Channel Kit
    manufacturer code : HX424C14SBK4/64 and
    CPU Intel® Core™ i7-6850K, 3.60GHz , Broadwell, 15MB, Socket 2011-V3

    Please tell me how to configure the RAM from BIOS to use all 64 GB of RAM installed.

    Thank You !
    Nowhere, do I see in this post you say you checked system browser.

    After building boards for years memory has done strange things, moving sticks has worked when they weren't shown. Strange how the UEFI doesn't see D1, but system browser does and Aida does.

    You should make sure all memory settings are default as sometimes the memory will be under clocked, and then try setting XMP to clock or over clocked.

    This has worked for some to see all memory. After this I would send asrock a support ticket as they might make you a UEFI with Improve DRAM compatibility for your situation.

    You can also wait for another suggestion. Hope you get it all showing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •