I've looked everywhere and cant find one. Just need something older than p1.50 or newer i guess. Just not that version.