my PC restarted in the middle of gaming yesterday and when it turned back on the audio was not working. i open playback devices in sound and the only thing that comes up is AMD HD audio device (for hdmi, thru my graphics card, i cannot use this with my monitor).
the realtek audio that came with the motherboard has disappeared. in device manager it is calling itself "high definition audio controller" and comes up under system devices instead of sound controllers. it has a yellow ! and saying code 10 this device cannot start. when running dxdiag, it says there is no sound card detected. i have worked for ten hours trying to fix it using every solution the internet has offered, to no avail.
things i have tried:


  • uninstalling high definition audio device from device manager. restart and let windows reinstall default sound
  • reinstalling realtek drivers from ASRock website. and realtek website.
  • using AMD cleanup utility to remove all graphics and sound drivers from AMD
  • reinstalling AMD graphics and sound drivers
  • boot into safe mode, use DDU to remove drivers. reinstall them manually.
  • checked onboard audio is enabled in BIOS. have toggled each option from enabled/disabled/auto and tested.
  • checked windows audio service, audio endpoint, and all dependant services are running. restarted them.
  • been into registry and deleted lowerfilter
  • reinstalled chipset drivers from CD that came with motherboard.
  • using a system restore point.


im all out of ideas, would a fresh install of windows work? im hesitant as i dont have a way to back up my files and dont want to lose everything. but i cant see any other solution going forward.
i got to a point yesterday during my messing around with drivers, where the sound started working again, but only for about 10 minutes before it crapped out and i was back to the start.

I use Z170M-itx/ac motherboard
HD radeon 7750 graphics card
windows 7 64 bit