Hello all,


I just recently purchased the ASRock Z370 Taichi and paired it with a 8700K. Due to the cryptocurrency craziness, I'm not going to purchase a new graphics card anytime soon. So I've decided to use my current GTX 770's in SLI. As expected from my post, I'm running into an issue. Every time I benchmark or play a game, within either 10 or 15 minutes (sometimes sooner) of benchmarking or gaming, the game or benchmark freezes. I can simply press ESC and both the benchmark or game closes. Now if I just have one GTX 770 installed, the benchmark and games run perfectly fine for hours on end. I've tried both cards in slot one and each successfully ran the benchmark and games just fine. These lockups are only occurring when both cards are installed with SLI. I've tried different SLI bridges. I've uninstalled and reinstalled drivers. The BIOS is updated to P1.30 and set to defaults. I've also updated the firmware on each card. Both have the same firmware version. When I put one card in the first PCI-E slot, no freezing. When I put one card in the second PCI-E slot, the benchmark/game freezes. So I'm narrowing it down to the second slot as being faulty.


Specs:
Case - Corsair 570X
ASRock Z370 Taichi - P1.30 - default BIOS settings
8700K - no overclock
Corsair H100i v2 CPU cooler
G.Skill Ripjaws V Series (2 x 8GB)
Samsung 850 Pro 256GB SSD
Corsair Gold AX1200 single rail PSU - 8 years old
2x EVGA GTX 770's - 390.77 drivers
Windows 10 Pro - fresh install


Curious if anyone has experienced this or has some insight?


Much appreciated!