Hi!

I'm setting linux on ASRock Z87 Extreme11/ac board right now and getting following reading from sensors:

Code:
user@linux ~ $ sensorscoretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +40.0C  (high = +80.0C, crit = +100.0C)
Core 0:        +37.0C  (high = +80.0C, crit = +100.0C)
Core 1:        +39.0C  (high = +80.0C, crit = +100.0C)
Core 2:        +40.0C  (high = +80.0C, crit = +100.0C)
Core 3:        +36.0C  (high = +80.0C, crit = +100.0C)


nct6776-isa-0290
Adapter: ISA adapter
Vcore:          +0.88 V  (min =  +0.00 V, max =  +1.74 V)
in1:            +1.86 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:           +3.39 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:          +3.39 V  (min =  +2.98 V, max =  +3.63 V)
in4:            +0.95 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:            +1.68 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:            +0.62 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:           +3.44 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:           +3.31 V  (min =  +2.70 V, max =  +3.63 V)
fan1:             0 RPM  (min =    0 RPM)
fan2:          2014 RPM  (min =    0 RPM)
fan3:             0 RPM  (min =    0 RPM)
fan4:             0 RPM  (min =    0 RPM)
fan5:          4736 RPM  (min =    0 RPM)
SYSTIN:         +36.0C  (high =  +0.0C, hyst =  +0.0C)  ALARM  sensor = thermistor
CPUTIN:         +39.5C  (high = +80.0C, hyst = +75.0C)  sensor = thermistor
AUXTIN:         +48.0C  (high = +80.0C, hyst = +75.0C)  sensor = thermistor
PECI Agent 0:   +40.0C  (high = +80.0C, hyst = +75.0C)
                         (crit = +100.0C)
PCH_CHIP_TEMP:   +0.0C
PCH_CPU_TEMP:    +0.0C
PCH_MCH_TEMP:    +0.0C
intrusion0:    ALARM
intrusion1:    ALARM
beep_enable:   disabled
UEFI/BIOS shows following status:
ASRock Z87 Extreme11/ac lm-sensors (linux) configuration-20180408_215315-jpg

Can someone help sensors configuration file to correlate output of linux sensors with UEFI/BIOS output?

Thanks in advance!

WBR, AG