This is a brand new custom build:

FULL SYSTEM:

CPU: AMD Ryzen 32-Core Threadripper
MOTHERBOARD: ASRock X399M Taichi
COOLING SYSTEM: Enermax Liqtech TR4 II
RAM: G Skill NT Series, Two 8GB Ram Cards
SSD: Samsung 860 Evo Series 2.5" SATA III, 500GB
GPU; Nvidia NVS 315
POWER SUPPLY: EVGA SuperNOVA 1000W


After assembling the unit and during the POST procedure, Dr. Debug continually cycles through six different error codes:

14, 07, 45, dE, Ad, A1

This pattern repeats itself over and over again. While this is occurring I am stuck on the ASRock splash screen and the keyboard is unresponsive (cannot enter UEFI or BIOS).

The BIOS is currently flashed to 3.20. I have tried reflashing to 3.30 back to 3.20 to no avail. I have tried using one RAM card in all DDR4 slots. I have reset CMOS multiple times. I have checked all connections and undone connections to all SATA devices, checked, then redone. Both the 4-pin and 8-pin connections on the board for the CPU are connected to the power supply. The CPU is definitely seated correctly. I am at my wits end here. There is one post where someone experienced the same sequence of error codes here:

new beta bios for X399 is up on ASRock site - ASRock Forums - Page 15

This person just reflashed the bios to a lower version and it solved the problem. It did not for me. This problem is on a new build and it happened from the start. I spoke with ASRock technicians and the only thing they suggested was trying different RAM, which I did, same response.

There are many instances of this happening with ASRock mother boards (freezing on splash screen, keyboard doesn't allow entry into UEFI/BIOS), and none of the solutions mentioned there have worked. I have no idea what can be causing this as I have tried everything under the sun. Tech support for ASRock was contacted again and they said it could be a bad board. How common is this? I submitted a return ticket with newegg but I want to be completely sure that I am not missing anything here...