I bought the Asrock B450M Pro 4 Motherboard with a 3-pin ARGB header. But when I connected my ARGB fans, one quarter of the LEDs doesn't get addressed. When I use the motherboard software from Asrock (ASRRGBLED) to address the fan LEDs, it only works for three quarters of the LEDs, the last quarter always stays blue and green for no apparent reason, even when I turn the LEDs off in the software.

Motherboard: Asrock B450M Pro 4
ARGB fans: Alpenfoehn Wing Boost 3 ARGB

Here are some pictures:

The first photo shows the fans actually turned off (or supposed to be) in the software. But the non-addressed quarter stays on with blue and green colors..


The second photo shows the fans turned on as red in the software. But the unadressed quarter of LEDs just stays the same color. Always blue and green for some reason.


I have tried changing the number of LEDs being adressed in the software from 0 to 80. I think my fans have about 20 LEDs since I only see any change between 0 to 20, but it only turns off som LEDs when I set it under 20. That setting doesn't fix the issue. The fans work perfectly with an external ARGB controller that I tried, but I much rather would like to use the mothermoard since it has more features and doens't need a special remote like the controller does.

Is my motherboard faulty?