Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on




  1. #1
    Join Date
    Apr 2011
    Location
    Montreal
    Posts
    4

    Default Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Hi,
    My computer crashed this afternoon. Somehow it happened when my friend came back from outside and opened the door to our house. (static shock?)

    Anyways, nothing seems to power on, there are only the LED on the Power and Reset buttons that blinks, while they should be always on. The computer does not start anyhow.

    I tried a couple of things (plug/unlug power cord, plug/unplug power pins to motherboard, unplugged everything connected to the motherboard except power) and it does nothing! I recently changed my motherboard with a RMA because of the B3 revision. I suspect I got a bad motherboard in exchange. The board did work for the last 2 weeks.

    video of the problem:
    http://www.youtube.com/watch?v=7KTwbknC0P0

    If you have any clear idea of what's going on, please enlighten me! Thank you

  2. #2
    Join Date
    Mar 2011
    Location
    Northern California
    Posts
    18

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    If you have not reset the CMOS you might unplug all connections and unplug the PSU and then push and hold the "reset cmos" button on the back I/O plate and then reconnect all power connections and see if the board will boot to the BIOS

    Just a thought in case you have not tried this.
    Kipper
    Hardware/Software Reviewer

  3. #3
    Join Date
    Apr 2011
    Location
    Montreal
    Posts
    4

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    I tried what you proposed (clear CMOS, unplug,replug everything on the motherboard), nothing seems to work. This motherboard is dead... after 2 weeks of normal use... so much for the "Deluxe". I'll go through the pain of a RMA with Asus.

    Thank you for your time and quick reply

  4. #4
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Can you try the long method of clearing cmos by removing mb battery,leave out overnight then put back in and try,tested with another psu just to be sure?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  5. Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Hi Louis,
    I sent you a PM.
    Mason Winner
    ASUS Tech Support

  6. #6
    Join Date
    Apr 2011
    Location
    italy
    Posts
    4

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Please have same problem, changed the psu, unmount all components, reset bios, removed battery for many hours, but only power and reset button go on.
    Sorry for my english, i'm italian.....
    Please Mason help me....

  7. Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    genoaole, so when you press the power button do any of the fans spin? also, please confirm that 24-pin power and 4/8-pin power pins are connected from the PSU to the motherboard.
    Mason Winner
    ASUS Tech Support

  8. #8
    Join Date
    Apr 2011
    Location
    italy
    Posts
    4

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Quote Originally Posted by ASUS - Mason Winner View Post
    genoaole, so when you press the power button do any of the fans spin? also, please confirm that 24-pin power and 4/8-pin power pins are connected from the PSU to the motherboard.
    Yes all connectors are putted in and no fans work at power on.....
    I have changed the psu but same problem. Unmounted ram (same problem) unmounted gpu (same problem), unmounted cpu (same problem)... RMA!?

  9. #9
    Join Date
    Apr 2011
    Location
    Montreal
    Posts
    4

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    I got it working without RMA by buying a brand new power supply. My other old power supply did not properly power the motherboard and the one I had in my case was obviously defec. The air is really dry in my house and I suspect an electrostatic shock with dust killed it.
    Good luck,


    Louis

  10. #10
    Join Date
    Apr 2011
    Location
    italy
    Posts
    4

    Default Re: Asus P8p67 Deluxe rev B3 problem: power button blinks, nothing powers on

    Quote Originally Posted by Louis View Post
    I got it working without RMA by buying a brand new power supply. My other old power supply did not properly power the motherboard and the one I had in my case was obviously defec. The air is really dry in my house and I suspect an electrostatic shock with dust killed it.
    Good luck,


    Louis
    Damn i have changed the psu with a new Antec High current gamer 800w but not work...
    Sorry not blink, led in power and reset button go on, but no fans work and no post in bios.
    Last edited by genoaole; 04-19-2011 at 05:09 AM. Reason: error

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •