As the title states, I have a P67 Revolution. I ran it for about a week and on one of my reboots it came up with no VGA, the VGA diag LED is lit and the diagnostic card reads or stops at 06. Has anyone else had any thing like this happen or know what this means, the manual says very little about the codes, a pdf I found says a little bit but it is also a bit cryptic. If anyone has any information about it or could give me some pointers on what I can do that would be great. I dont think it is an issue with my other components, because I replace the board with my GA-Z68-UD7 and all is well. Sort of, that board has its own separate issues. I have also tried 4 different video cards, multiple memories and nothing seems to work. Only the bare essentials installed results in the same issue. My specs are below and I would appreciate any help anyone wants to offer. Thanks very much.

Intel 2600k
Asus P8P67 WS revolution rev. 3.0
2 MSI 6950's or 2 XFX 4850's or each of them separate.
Corsair Dominator memory 16 gb, also 6 gb ocz platinum
Antec Kuhler 920 water cooler.
Crucial SSD, WD black HDD's RAID 0
Corsair 750 Watt Power supply
Cooler master Cosmos case