Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asus X555LD RAM expansion problem




  1. #1
    Join Date
    Dec 2014
    Location
    Israel
    Posts
    1

    Default Asus X555LD RAM expansion problem

    Hello,

    I've recently installed 8 GB of ram into my computer.
    I can see the memory in CPU-Z but cannot see it in BIOS or Windows.
    The memory I've installed is Kingstone 8GB 1600Hz and I've also tried 4GB 1060Hz and 2GB 1060Hz.
    Because CPU-Z recognizes the stick can I rule out hardware problem?

    Thanks

  2. #2
    Join Date
    Jan 2015
    Location
    Greece
    Posts
    2

    Default Re: Asus X555LD RAM expansion problem

    Dunno if u solved the problem, and sorry for the bump but ill try to help cuz i encountered a somewhat same issue recently. Cpu-z also recognized the ram but not the bios and windows.
    For me the problem was i bought a ram incompatible with my asus laptop. I bought a 4gb 1600mhz DDR3 while i actually needed the same but DDR3L. That means low voltage 1.35v while the one i bought was 1.5v. Check it because if my lap x550LN uses low voltage ram, its possible yours do too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •