Hi
I recently have to use a recovery partition, because of windows black screen issue (while this, notebook has been force-turned off several times by me while going, or even being into S3 sleep mode which I realized after a repairing a windows). After my "repair" Windows OS came back to its old life, but BIOS started to freak out.

1. When OS (Windows or Ubuntu, doesn't matter) request a sleep mode from bios, it blanks out the screen and that's it. I can hear a fan running, and see indicators flashin. BIOS does not support any other sleep mode than S3 or S4.

2. When OS request a restart from bios, it hangs on, turning off a whole notebook, and from time to time turning it on after a second or two. Before that issue, notebook was restarting flawlessly without a complete shutdown

3. When OS request a shutdown from bios, it hangs on, on black screen.

4. When OS finishes a hibernation, and requesting a hiber-shutdown, same happens. Hibernation files are complete, and after force-shutdown via button press, I am able to wake up from hibernation.

5. Bios freeze when I push power button on the BIOS settings screen, instead of shutdown

Also after changing any bios settings selecting "save and exit" screen becomes black longer than usual with additional " _ " solid sign (just like a cmd blinking dash, but solid here) in left upper corner which was never happening before. BIOS remembers new settings after all.

I have tried to reset bios settings, but problem remains, also removed a case and tried without SSD connected, bios still freezes when pressing power button, and then I was looking for a CMOS battery, but it seems that when main battery is not removable, there won't be any CMOS battery. Batt connector is hard to unplug, or it uses some lock mechanism, so I don't want to break it.

I even downgraded bios from 208 to 207 succesfuly (sadly there is no 208 ver avaible to download, only 207), but problem remains
Any ideas how to "disable" this weird bios mode?