Hey all,

Looking for some help on a problem which has been really confusing me all day. I've had an ASUS A52F for around 3 years and it runs windows 7 64 bit. Standard the laptop came with 3GB RAM, 1 x 2GB stick and 1 x 1GB stick.

I recently done a wipe and restore of the system as it was running very slowly. I thought what the heck I'll add some extra RAM to help it's performance a little more also. I used crucials scanning tool to identify which spec of RAM I needed and wen't ahead and ordered the same spec of RAM from a different manufacturer on ebay. The RAM i purchased can be seen at this link

HTML Code:
http://www.ebay.co.uk/itm/201513136612
I have received and installed the RAM but now windows won't boot for some reason. I have tried removing the sticks and replacing them in different slots and also tried booting with only one stick installed at a time. The same things always happens, as soon as the starting windows screen appears the computer restarts. I've tried starting with the startup recovery tool as well and again it goes to "windows is loading files" screen then as soon as the starting windows screen appears the computer restarts.

I thought re-installing windows would fix the problem but the same things happens when i try to boot from a usb, it goes to "windows is loading files" then as soon as the starting windows screen appears the computer restarts.

It would appear the RAM isn't compatible but the spec is identical so I dont understand how this can be so. Is it something that needs changing in the BIOS to make it recognise the new RAM sticks?

If the sticks are indeed totally incompatible then I will have to return to the sender on ebay and then just buy the crucial units.

Any advice greatfully received,

Ryan