Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Asus Z170-Pro hard drive disappears after reboot?




  1. #1
    Join Date
    Aug 2009
    Location
    New Jersey, USA
    Posts
    44

    Default Asus Z170-Pro hard drive disappears after reboot?

    I just put together a brand new system and it uses an Asus Z170-Pro, a Intel i7-6700K and a Western Digital 2TB Black hard drive (this is not the first system I built using this combination), the hard drive is attached to the sata port that is indicated for the "OS Drive" and I was able to install Windows 10. But everytime I reboot the computer the hard drive disappears from the bios. What I mean by that is if I boot from a shut down state the computer sees the hard drive and will boot from it but on a warm reboot the system won't boot and most times takes me into the bios and if I go to the PCH Storage configuration I can see the DVD drive but the sata port where I would normally see the hard drive is showing no drive attached.

    I'm currently using the most recent bios available from the Asus web site 2202, I've also swapped the sata cable for the hard drive with one of the spares that came with the motherboard but I'm still having this problem.

    Has anyone seen something like this? Any idea's how to fix it?

  2. #2
    Join Date
    Aug 2009
    Location
    New Jersey, USA
    Posts
    44

    Default Re: Asus Z170-Pro hard drive disappears after reboot?

    I spent an hour and a half on the phone with Asus tech support and after running through everything, including swapping in a new hard drive and installing the OS on it I still have this problem. The Asus tech conclusion is that this latest bios has a bug that's causing this problem since I have another computer that uses this same motherboard but has a slightly older bios and it does not do this.

    For some reason neither the bios Flash utility or the AISuite Flash utility will flash any of the previous three versions of the bios, each time it complains that the bios image is not a correct image, does anyone have any idea if there's another way to flash the bios without having to buy a replacement bios chip to down grade to a previous version?

  3. #3
    Fastclass is offline Junior Member
    Join Date
    Jan 2017
    Location
    Canada
    Posts
    1

    Default Re: Asus Z170-Pro hard drive disappears after reboot?

    Hi I just joined tweaktown because I have the EXACT same problem! The only difference is I use my WD 2tb for media, iphone backups, games, movies etc. My drive disappeared twice, first on Jan 8 and again last night! I got it working by shutting down the PC completely then unplugging the PSU, checking cables, unplugging drive but not changing which port it was plugged into then it worked like usual, the 2nd time (last night) I just shutdown pc and unplugged PSU and it was fine again.... but now I'm thinking to update the BIOS with EZ FLASH 3.
    Before I update did you solve the problem? Did that EZ FLASH 3 work? I'm afraid to update since I never had anything wrong with my old ASUS sandy bridge setup.
    Thanks in advance for any reply!

  4. #4
    Join Date
    Aug 2009
    Location
    New Jersey, USA
    Posts
    44

    Default Re: Asus Z170-Pro hard drive disappears after reboot?

    Quote Originally Posted by Fastclass View Post
    Hi I just joined tweaktown because I have the EXACT same problem! The only difference is I use my WD 2tb for media, iphone backups, games, movies etc. My drive disappeared twice, first on Jan 8 and again last night! I got it working by shutting down the PC completely then unplugging the PSU, checking cables, unplugging drive but not changing which port it was plugged into then it worked like usual, the 2nd time (last night) I just shutdown pc and unplugged PSU and it was fine again.... but now I'm thinking to update the BIOS with EZ FLASH 3.
    Before I update did you solve the problem? Did that EZ FLASH 3 work? I'm afraid to update since I never had anything wrong with my old ASUS sandy bridge setup.
    Thanks in advance for any reply!
    No, the problem hasn't been fixed and Asus hasn't given me any reason why you can't flash to previous versions of the firmware. Neither the bio flash util or the AISuite flash util will down grade to a previous version.

  5. #5
    maximus61 is offline Junior Member
    Join Date
    Apr 2017
    Location
    Norway
    Posts
    1

    Smile Re: Asus Z170-Pro hard drive disappears after reboot?

    Hi
    I had the exact same problem after upgrade to latest bios v.3201
    I had to flash back to 2202 . Only way to do that is to use the usb bios flashback. put the bios file on a fat32 formatted usb 2 stick. rename file to Z170?.cap ( i have a deluxe board so I had to rename to Z170D.cap ) So use the correct name. my guess is Z170P.cap , you having a pro board :-)
    turn of your machine, pull power plug. Insert usb stick in correct usb port at the back ,refer to manual. Re insert power. press the bios_flbk button for 3 secons and wait until the light in the small led above goes off. wait 5 min to be sure. Thats it.
    hope it works for you. :-)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •