Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: UEFI BIOS black screen (H87M-PRO/G10AC)




  1. #1
    yk_dast01 is offline Junior Member
    Join Date
    Jan 2017
    Location
    Prague, Czech Republic
    Posts
    1

    Default UEFI BIOS black screen (H87M-PRO/G10AC)

    Hello, I have the following problem:


    My UEFI BIOS config screen does not show up. I press DEL or F2 when it starts up, only to see a black screen.
    This problem arose shortly before I replaced my GPU to Nvidia GTX 1060, but it was already present with the old GPU about two months ago.
    However, a bigger problem is that I cannot update my BIOS either, because my Windows boot files were corrupted, so I can't just download and install new BIOS files. To fix this, I need to boot the windows repair tool from a USB drive, but I need a working UEFI BIOS for that.
    You see the problem? I cannot see the UEFI BIOS interface to repair the OS, and I cannot access the OS, to update the BIOS.


    A solution I tried so far - restarting BIOS by reinstalling its lithium batter - did not solve this problem. I can see the BIOS starting up and in a short while I am greeted with Windows message telling me that I need to repair my system boot files. However, when I try to access the UEFI, I get a black screen, which I can only exit by either pressing CTRL ALT DELETE (which restarts the machine) or just turn it off by pressing the power button. Replacing the power supply with a brand new Zalman zm600lx didn't do much either. Also, I tried to connect it to a different TV screen (using the same HDMI cable) but to no avail -the issue persists.


    I cannot post my full specs, because I am writing from another device, but I will try:
    My motherboard is H87M-PRO/G10AC/DP-10 (or DP-IO - it is hard to see the name inside the case).
    I do not know my BIOS version but it should not be later than September 2013, which is G10AC BIOS 0702 or earlier.
    My graphics card is Nvidia GTX 1060, connected to an LG Flatron M227WDP TV monitor with an HDMI cable.
    PSU is Zalman ZM-600LX
    My CPU should be Intel Core i7 4770.
    The OS is Windows 10 64 bit.

    So, in short: I cannot see the UEFI BIOS config to fix corrupted Windows boot files. UEFI BIOS screen just goes black - tried it with two different GPUs. Failed solutions: replacing PSU, restarting BIOS with the battery reinstallation, using a different tv/monitor, connecting motherboard and monitor with a VGA cable (GPU removed).

    I will be happy to hear your suggestions.

    UPDATE#1:
    I tried using a VGA cable connecting the motherboard and the monitor. The problem still persists, though this time I could not restart the machine using CTRL+ALT+DEL for some reason. But the cable connected the display fine - I saw the splash screen and the Windows error message as usual but in a better resolution. However, still no way to see the UEFI settings screen.
    Last edited by yk_dast01; 01-04-2017 at 10:05 PM. Reason: New attempt with a VGA cable

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •