Here is the situation:
I've tried a fresh install of Win10 on my X202E and after the installation finished computer went into "Wait for (something)" and stayed there forever.
After an hour or so I've decided that enough is enough and I did a hard reset. After the reboot computer got into "Wait for (something)" again, got stuck there, and after some time I did a hard reset again.
And then it didn't want to boot at all.
The LEDs would lite up, I could hear the HDD spinning but the monitor was off and then everything would go silent (LEDs still on).
Since the computer was unplugged during the installation I could be pretty sure that it's not a hardware damage but I had to figure out what's wrong.
And a friend of mine suggested that it might be a corrupted BIOS.
I've looked on-line, saw that I can buy a programmer (CH341A) for 5$, ordered one and (in the mean time) searched for the dump file for my computer so I can flash it once I have the programmer.
Found the dump file, programmer arrived, unsoldered the BIOS (actually UEFI) chip and programmed it (saved the original dump).
And, voilą, I was up and running again.
There was only one problem.
Network card (Atheros AR8162/8166/8168) was not recognized by the system (neither Win10 nor Ubuntu). I assumed that this is because the dump file was from another computer so I've flashed the
original ASUS BIOS using WInFLASH. No changes.
Thought that some of the other UEFI part might be the issue (GbE Region - but as far as I understand this is only if you have an Intel NIC. I can be completely wrong about it).
Since the BIOS region is the only thing that got corrupt I've replaced all the parts except the BIOS from my saved dump file, but again no effect.
Then I've compared my corrupted BIOS with the working one (with HxD) and I saw that a big number of lines got erased (turned to F's) so I've copied those lines from the working one to the
corrupt one and managed to boot. Still no luck.
So, I'm asking the experts for help.
What could be the problem and what can I do to fix it?
Any advice is welcome.

P.S.
Just for the clarification, when I say not recognized I don't mean that the device is seen as "Unknown", it's just not there (in the Device Manager or when I type lspci).
P.P.S. I've already tried a bunch of dumps for a version 2 of the motherboard but none of them seems to work. I'm not sure how much the boars are different (Specifications on the
ASUS site are identical for both versions) but it might be simply that BIOS is looking for the MAC address and the LAN card on the wrong place.