One of my native sata ports ceased up on my old legacy mobo (ASUS Striker Formula II) and as a workaround I went out and bought a cheap pcie card that would add another 6 sata 3 ports since I need a few extra sata slots for my NAS server.
Once the card is in the system (*no disks connected to the any sata ports on the card), it refuse me into bios settings and seem to halt with this screen message...

Asmedia 106x SATA Controller ver 1.00 AHCI Mode
Using PCIE Gen 1 x2
Firmware version 140924_00_00_00
Port   PMP   Model
  0       0     ASMT109x- Config SATA 3
  1       0     ASMT109x- Config SATA 3

Clearly the pcie card has been recognized somehow, but Im not able to boot my FreeNAS linux system, nor enter bios settings once this card is installed.

When the system boots, I see the boot wall paper with option to press Delete to enter bios - doing so brings up a message like its trying, but rather than taking me there, the message is displayed on a black screen - from there I dont seem to be able to do anything - Its like its waiting for me to do/configure/confirm something...?

I have tried the card on both generic white pcie 16 slot and blue pcie 16 slot - same result Board with 100% compatible PCIE v2 slots

This is the Marvell Chipset Non-Raid PCIE card I got ...
PCI-E To SATA 3.0 6-Port SATA III Expansion Card Marvell Chipset Non-Raid AC1723 4894663290146 | eBay

Anyone sitting on some info that would allow me to use this card it would be appreciated.