Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ATI Remote Wonder - problem




  1. #1
    Join Date
    Sep 2004
    Posts
    1

    Question ATI Remote Wonder - problem

    I've used Tweaktown's guides to speed up my boot times and just improve my system in general for gaming, but for some reason, now my ATI Remote Wonder doesn't work anymore. I'm able to start the program and it shows up in my running processes, but the familiar RW icon doesn't show up in the program tray by the clock and the remote doesn't respond at all, though there is a light on the receiver and new batteries in the romote. Any idea what kind of service I might have disabled to cause this? I've tried re-enabling a few services that I thought might have something to do with it (i.e. human interface devices, ATI Smart, HotKeyPoller, etc) to no avail. I remember editing some registry entries with one of the tweak guides, but now I can't remember which guide I used or which entries I might have altered. I really don't want to have to reformat and reinstall everything just for this so I hope someone here might be able to offer some help (the ATI site is no help at all).

    Thanks in advance.

    Dan in Omaha

  2. #2
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default Re: ATI Remote Wonder - problem

    You might try removing the hardware and software from Control Panel, then reboot and reinstall the whole thing. That should replace any services that might have inadvertently been removed during the tweaking.
    Old age and treachery will overcome youth and skill
    My Toys

  3. #3

    Default Re: ATI Remote Wonder - problem

    I ran into this same issue after applying tweaks to Windows XP.
    I'm going to take a guess that you applied the tweak disabling 8.3 filename creation on NTFS. (That's what happened to me)

    Ironically, doing the uninstall/reinstall of the drivers will only make the problem worse.

    Here's a fix:
    To start fresh, unplug your ATI remote, uninstall the ATI Remote Wonder driver, reboot the system.
    Reinstall the ATI Remote Wonder driver, reboot, and plug your ATI remote wonder back in. You will not have a working remote yet...but you'll hopefully have a clean install that doesn't contain any of the attempts you may have made to fix the problem (I know I play around with things to the point where they become more broken, so its good to start fresh)
    Next...
    Click Start then Run
    Type RegEdit
    This will launch the Registry Editor
    hit CTRL+F (this will launch the Find dialog).
    Uncheck all boxes except for "Data"
    Type "RemCtrl"
    Hit F3 until you find a key in the registry that reads something like

    c:\windows\system32\rundll32.exe C:\Program Files\ATI Multimedia\RemCtrl\(some file name).dll,EntryPoint
    It may also look like:
    c:\windows\system32\rundll32.exe C:\PROGRA~1\ATIMUL~1\RemCtrl\(some file name).dll,EntryPoint
    -- or any variation of the 8.3 (short) or long file name --

    The important part here is the section after rundll32.exe and before the comma. You need to replace the path with the correct, complete long filename path to that file and put a quote before the C:\ and before the comma.
    If you've done it right, it should look something like this ...

    c:\windows\system32\rundll32.exe "C:\Program Files\ATI Multimedia\RemCtrl\(some file name).dll",EntryPoint

    On my system there were 3 or 4 registry entries that have some variation of the above. If it doesn't say rundll32.exe in the value data, don't change it.

    And of course, after all of this, you have to reboot your computer. If you did it right

    [explanation]
    The reason that this happens is because the ATI Remote Wonder Installer preferred to use the 8.3 filename instead of the long filename. When the installer uses the 8.3 filename, it doesn't need to include quotes because 8.3 filenames do not have spaces in them. When the installer went to create that key, it looked up the 8.3 filename but retrieved the long filename. It didn't figure out that it needed to place quotes around the parameter specified for rundll32.exe because it didn't expect to get a filename with a space in it.

    You can't simply re-enable 8.3 filename creation to fix this problem without going through recreation of the directories the files were contained in (explained later).
    You will encounter this error on *every* driver upgrade to the ATI Remote Wonder, and it appears to also affect the ATI Catalyst Control Center program as well. Unless ATI fixes the driver install (unlikely for the Remote Wonder since X10 provides the drivers), expect to take these steps each time. You may need to search for different paths with future installs, but the key problem is the lack of quotes.
    [/explanation]

    [soapbox]
    I have to blame ATI on this one, but they are not the only ones to blame. I have had several application installers do this same thing. Some of the installers actually crash because they only expect the 8.3 filename and when they retrieve something thats longer than 12 characters, they fail.
    Based on the issues I've had, I strongly recommend against applying the NTFS tweak that disables 8.3 filename creation. Too many install scripts are written poorly and you will have problems.
    ATI appears to have this problem in every version of their remote wonder software (though I only tested it on 1.4 and 2.4). And it appears that their catalyst control center installer does this same thing.
    [/soapbox]

    The 8.3 filename problem will show up elsewhere. I don't know of any long-term solution to "back out" of the tweak. You *can* simply turn back on the 8.3 filename creation, but AFAIK it will not apply 8.3 files to existing directories and files that were created while the tweak was enabled.
    Short of re-creating every file on your drive, you're stuck with it. I'm not sure if there is a way to force the OS to go back and create 8.3 filenames for existing files. If someone knows, that'd be nice to be able to do.

    I advise against using the 8.3 NTFS filename tweak. It provides a small performance benefit, but because of shoddy programming/QA of some vendors, you can expect to run into this problem elsewhere.

    Hope this helps you out!
    --
    acousticiris

    Standard Disclaimer:
    The information contained within this post should not be considered an actionable contract, or legal advice. It should not be used as a reference for reports of any kind. Any facts stated within this e-mail should not be assumed to be accurate (not even for a middle-school research paper). The author of this post assumes no responsibility for its content. It is provided AS IS without any warranty, expressed or implied. If you depend on this information for any reason and incur any loss (or profit) as a result of it: you are responsible for such loss (or profit). As I will not ask for your profit, I will not compensate your loss. If the content of this post concerns you, please contact (248)262-6861 (Michigan, USA call) directly.

  4. #4
    Join Date
    Jan 2005
    Posts
    1

    Default Re: ATI Remote Wonder - problem

    I've got the same problem. No icon in the tray, no functionality for the remote, but ATIRW.exe is running, and when I call it up from the start menu tray icon is checked.

    I had the same problem in the registry you described. In addition I got a "rundll as an app" error upon boot. I do not remember "consciously" tweaking the 8.3 file handling.

    At any rate, I made the changes in the registry after uninstalling and re-installing the entire ATI suite. My startup error has disappeared, but the remote has not come back.

    In addition I found that ATI has put garbage in the registry: Instead of c:\etc.etc. for file names, I've found over 2K c?\etc.etc. for file names!!!!!!!!

    The only way I could feasibly change it (by hand would be ridiculous), was to (after a system checkpoint!) export the registry section, edit and globally fix the entries, and install the .reg file back.

    I did this *before the uninstall/re-install, and found that it had but some back, which I treated again.

    End result. Still no remote control. Oh Well...

    Thanks for your reply to the previous person's problem!

    DHK

  5. #5

    Default Re: ATI Remote Wonder - problem

    It sounds like the problem you're having is different than the one I ran into.
    I also have several entries with C?\xxx\yyy. Very odd, but it didn't seem to affect it.

    If you did run into any of the RunDLL problems, you can actually test it by executing the command and seeing if something launches. RunDLL32 will ONLY return error messages if the Entry point specified is invalid. It will do nothing if the file isn't found, the syntax is incorrect or some other issue arises. Sometimes when it works it's not entirely easy to tell that it worked. With the Remote Wonder, however, it launched an app that was visible in the Processes tab when the command was entered properly

    [more]
    RunDLL32 is executed in the following manner:
    %windir%\system32\rundll32.exe (dllname),(entrypoint)

    On my system it would be something like this

    C:\Windows\system32\rundll32.exe "C:\Program Files\SomeDLL.dll",SomeFunctionEntryPoint

    No spaces should exist between the comma and the closing quote.
    [/more]

    Good luck!
    --
    ai

  6. #6
    Join Date
    Jan 2005
    Posts
    1

    Default Re: ATI Remote Wonder - problem

    Acousticiris, Thanx so much. I have been trying to fix this remote problem for days, and your reg fix worked like a charm.

  7. #7
    Join Date
    Feb 2005
    Posts
    1

    Default Re: ATI Remote Wonder - problem

    I applied the fix to the registry entry shown below.

    C:\WINDOWS\system32\rundll32.exe C:\PROGRA~1\ATIMUL~1\RemCtrl\x10net.dll,EntryPoint

    simply added the quotes as shown below and blamo it worked. My system has not been tweaked in any way. Just running WinXP SP2 under NTFS.

    C:\WINDOWS\system32\rundll32.exe "C:\PROGRA~1\ATIMUL~1\RemCtrl\x10net.dll",EntryPoi nt

    Just wanted to point out that the fix will also work for people who have not 'played' with their systems. My problem was a bit strange and I have not found anyone else with it. After installation the remote would work. Only on every second boot would the remote work. Don't know why but it works every boot now.

    Good stuff,

    Dave A.

  8. #8
    Join Date
    Feb 2005
    Posts
    1

    Default Re: ATI Remote Wonder - problem

    Hey guys,

    I got a similar problem.

    I just purchased a Remote Wonder "2", and it was working for a hour uninstalled it to install another verison ATI.com recommended.

    And now, I can't see the RW icon on the system tray and my receiver doesn't light up when I press a button on the remote. Is the reciever dependant on the RW software or just power from the USB to detect a signal from the remote?

    I tried to uninstall everything and reinstall, and that didn't seem to work.
    I also tried the registry hack, tried new batteries, old drivers, even tried it on another PC.

    Any ideas?

  9. #9
    Join Date
    Mar 2005
    Posts
    1

    Unhappy Re: ATI Remote Wonder - problem

    Having a slightly different problem. After installing the drivers, and rebooting windows XP SP2, I plugged in the USB Reciever. Windows attempts to install the driver for the reciever and the RW2 and stops at the same error on both "unable to locate AtiCoInst.dll". I have searched the system, and the OEM CD and cannot find this file anywhere?

  10. #10
    Join Date
    Jun 2005
    Posts
    2

    Default Re: ATI Remote Wonder - problem

    I'm really stumped on this ATI remote wonder problem. Like a few others in this post I can install the driver, reboot, and see the atirw process running from the task manager. I have yet to see the little remote icon in the tray though. I have a red light on the reciever and it is detected and installed properly in the device manager. It's all coming down to the ati remote software not running properly at startup. Is atirw.exe the only program associated with the remote wonder? When I run it myself all it does is bring up the configuration program...no tray icon. The show tray icon and run on startup options are checked by the way. I have tried the registry renaming scheme used previously in this post, but still no tray icon to confirm the remote software is running. I have tried four different versions of the remote wonder software, uninstalling and removing registry keys for remctrl before each installation. It just seems like I'm missing the program that brings up the tray icon and watches for the remote. Does anyone know which .dll or .exe is associated with the tray icon. I am using the very first version of the remote wonder with Windows Xp Pro SP2. Does anyone know of any third party drivers or programs to get this thing working, I'd hate to just toss it. Thanks for reading this post and any help you can give.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •