Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: No surround in games in Vista




  1. #1
    Join Date
    Oct 2004
    Location
    Jämtland, Sweden
    Posts
    128

    Default No surround in games in Vista

    I've got an Auzentech Digital X-Mystique soundcard, and I can't get surround sound to work in games in Vista. I've looked around the net, and from what I understand Microsoft, the geniuses they are, removed support for DirectSound when they made Vista. The games I've tried so far, like Half-Life 2 or Homeworld 2, won't output surround sound, regardless of settings in either Vista or the drivers. Half-Life 2 seems to default to stereo no matter what I do (again, the lack of DirectSound), and the only game that I can get surround sound from is Unreal Tournament (it supports Dolby ProLogic)...

    1: Does anyone know of a possible workaround? Creative users have the ALchemy project, sure, but what about the rest of the world? Does this problem apply to all non-X-Fi-cards??

    2: Will the upcoming XAudio2 API solve this somehow? From what I've read, no, but don't blame me for being hopeful... hell, the least those a**holes could do would be to throw in some backwards-compatibility into it... I don't understand how they could simply remove, basically ALL surround support for games! Or are there some games/soundcards other than those supported by ALchemy which are unaffected?


    Thanks for any input on this.
    Last edited by ifander; 08-29-2007 at 11:30 PM.

    Chieftec Bravo LBX01-B-B-SL
    580 W Hiper Type-R PSU

    Gigabyte GA-K8NXP-9 S.939
    AMD Athlon 64 Venice 3000+ at ~2470 MHz
    OCZ Gold EL PC 3700 Ram, 2.5-3-3-8 at ~456 MHz,
    2x512 MiB
    Gigabyte SilentPipe X800XL, 400/490 MHz
    Auzentech Digital X-Mystique 7.1CH DDL-RCE
    Logitech Z-5500 5.1 speakers
    1 x WD Caviar 8 MiB cache 1600JS-00MHB0 160GiB SATA-2
    3 x WD Caviar SE 16 MiB cache 2500KS-00MJBQ 250GiB SATA-2



  2. #2
    Join Date
    Oct 2004
    Location
    Jämtland, Sweden
    Posts
    128

    Default Re: No surround in games in Vista

    I just noticed that Max Payne 2 works with surround enabled, and it uses DirectSound as far as I know... wouldn't that mean that it should be possible to enable surround sound in other games?

    Chieftec Bravo LBX01-B-B-SL
    580 W Hiper Type-R PSU

    Gigabyte GA-K8NXP-9 S.939
    AMD Athlon 64 Venice 3000+ at ~2470 MHz
    OCZ Gold EL PC 3700 Ram, 2.5-3-3-8 at ~456 MHz,
    2x512 MiB
    Gigabyte SilentPipe X800XL, 400/490 MHz
    Auzentech Digital X-Mystique 7.1CH DDL-RCE
    Logitech Z-5500 5.1 speakers
    1 x WD Caviar 8 MiB cache 1600JS-00MHB0 160GiB SATA-2
    3 x WD Caviar SE 16 MiB cache 2500KS-00MJBQ 250GiB SATA-2



  3. #3
    Join Date
    Sep 2007
    Location
    Riverside, CA
    Posts
    5

    Default Re: No surround in games in Vista

    works fine for me. X-Fi here dude.

    Vista Ultimate 32 bit.
    Intel C2D E4300 @ 3.0GHz/EVGA 680i SLI 122-CK-NF68-A1/Wintec AMPO 2x 1GB DDR2 800/PNY 8800GTS 320mb @ 620/1800/SB X-FI Xtreme Music/Maxtor 300GB/Seagate Barracuda 7200.1 2x80GB & 1x 320GB/Antec True Control 550w PSU/Dual 19" NEC LCD displays
    -------------------------------------------------------
    AMD Athlon64 4000+ @ 2.7GHz/ASrock DualSata2/Mushkin 2x 1GB DDR400/Sapphire 9800Pro 128mb/Enermax Whisper 430/Westy W3 37" LCD

  4. #4
    Join Date
    Oct 2004
    Location
    Jämtland, Sweden
    Posts
    128

    Default Re: No surround in games in Vista

    Yeah, that's the thing... you've got an X-Fi...

    Chieftec Bravo LBX01-B-B-SL
    580 W Hiper Type-R PSU

    Gigabyte GA-K8NXP-9 S.939
    AMD Athlon 64 Venice 3000+ at ~2470 MHz
    OCZ Gold EL PC 3700 Ram, 2.5-3-3-8 at ~456 MHz,
    2x512 MiB
    Gigabyte SilentPipe X800XL, 400/490 MHz
    Auzentech Digital X-Mystique 7.1CH DDL-RCE
    Logitech Z-5500 5.1 speakers
    1 x WD Caviar 8 MiB cache 1600JS-00MHB0 160GiB SATA-2
    3 x WD Caviar SE 16 MiB cache 2500KS-00MJBQ 250GiB SATA-2



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •