Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: Visiontek ATI HD 2900 XT Beeps/No video




  1. Default Visiontek ATI HD 2900 XT Beeps/No video

    Just received a brand new HD 2900 XT this week, installed it but the onboard fan powers up and down for about 5 times over 30 seconds after finally powering up to a constant speed. After reaching speed, the BIOS beeps 1 long beep followed by 3 short beeps. Also, not sure how important this is, but the CD/DVD rom lights turn off and on while the video card fan powers up and down. It's like the video card is surging the power from everything else.

    Computer specs:

    Asus A8N32-SLI Deluxe
    AMD Athlon 64 X2 3300+
    2 - Kingston 512MB DDR3200
    2 - Buffalo 1GB DDR3200
    Thermaltake 600W power supply

    My last video card was an ATI Radeon X1900 XT. I would be getting problems during game play or video editing where the video would spike or flicker. Recently I loaded Crysis and I wouldn't even be able to play the game because the screen would go black depending on where you would move the mouse. During games such as COD4, render spikes would shoot straight out the top of character's heads. Very strange. Most games act this way.

    I'm not sure if it's a power supply issue with the HD 2900 XT, a motherboard issue with the PCI Express slot since it had issues with my last card, or a bad card? Any suggestions?

    Thanks!
    Last edited by depthofperception; 12-26-2007 at 11:44 PM. Reason: misspelling

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •