Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Sapphire Radeon HD 4670 in Crossfire




  1. #1
    Join Date
    Sep 2008
    Posts
    1

    Default Sapphire Radeon HD 4670 in Crossfire

    Just got this card from Newegg. Possibly DOA. Replaced fully functional Nvidia 7600 GT & got dreaded 2 short beeps, 1 long beep. Hopefully, flashing bios upgrade may work. Fan works, doesn't appear to be electrical problem. System is HP Pavillion HTPC (year & 6 monts old).

    Any thoughts???

  2. #2
    Join Date
    Sep 2008
    Location
    Canberra, Australia
    Posts
    206

    Default Re: Sapphire Radeon HD 4670 in Crossfire

    what kind of psu have you got... sounds to me like you havent got enough juice
    NZXT Lexa BlackLine Case with Red LEDs
    Corsair TX-750 Modular PSU
    Gigabyte EP45-DS3P (BIOS F7)
    Intel Core 2 Quad Q9300 @ 3.73GHz (downclocked for the summer )
    OCZ Vendetta 2 CPU Heatsink
    2x 2GB Kingston HyperX RAM PC2-6400 @ 996MHz (4-5-5-15)
    3x Seagate Barracuda 7200.11 500GB HDD in RAID5
    2x HIS Radeon HD 4850 @ 745/1090 in CrossFireX
    2x ThermalTake DuOrb GPU Heatsink
    D-Link Super G PCI WLAN Adapter
    Asus Lightscribe 20x SATA II DVD-DL Burner
    Creative X-Fi XtremeGamer Fatal1ty Pro
    2x 22" LG W2252TQ-PF Widescreen LCD Monitor (YAY!! Finally got the second one!!)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •