Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 8 of 8

Thread: Second Screen no long working?




  1. #1
    Join Date
    Sep 2008
    Posts
    5

    Default Second Screen no long working?

    I have been running a 4870X2 for a while now with a 19" monitor and a 33" HDTV... I've never had any problems with it untill I had to refit my 8800GTX to show it was still working for the guy who wanted to buy it, I already told him it was probably going to give me loads of problems messing with the drivers and boy was I right.

    When I had the 8800GTX in windows started updating drivers through windows update, and froze the PC.. When I wanted to reboot there was no video signal and the only thing that fixed it was just refitting my 4870X2 once again, then taking it out again and putting the 8800GTX back.

    Now that I've sold my 8800GTX I can no longer get my TV to run on my 4870X2 anymore.. Usually it would even show the post screen and windows booting on my TV, but right now it won't even run with only the TV plugged in. The 19" monitor still works fine, and when I want to extend my desktop the the TV in CCC the screen flashes once and then nothing happens, still can't see anything on the TV.

    I've hooked up the TV with an HDMI cable attached to a HDMI>DVI dongle.. I've already replaced to dongle to see if that was the problem but it's still not working.. Now I don't want to run off and buy a new HDMI cable for 70$ if this is also not going to work.. It would seem strange to me anyway because the HDMI cable has barely even been touched.

    I've already tried all the basic stuff like reinstalling drivers etc, I've even just done a format and installed the latest catalyst drivers (8.9) in the hope that I can finally watch my movies again on my tv.. But no such luck, still the same problem.

    I really hope someone can help me with this because im really close to freaking out... I might've made some money selling my 8800GTX, but right now it isn't even worth it looking at all the trouble it caused.

    My specs:
    Win Vista Ultimate X64
    Q9450
    EX38-DS4
    HD4870 X2
    Xfi Xtreme Music

  2. #2
    Join Date
    Nov 2007
    Location
    Australia
    Posts
    286

    Default Re: Second Screen no long working?

    That is a very bad mistake u just did... u should aLWAYS uninstall all traces of old graphics drivers b4 installing a new set.

    I tink u may also need to activate dual displays in catalyst control center. PLUS when u plug in the TV, since the primary monitor is the 19" screen, the secondary display will stay black without any image displayed on it.

    firstly u shoudl check wether the TV is even detected by going to screen properties in windows.
    Asrock P55-Extreme
    Core I5 @ 3.2GHZ
    2x2GB G.skill Ripjaws DDR3 1600
    ASUS HD5850
    1TB Samsung SATA II
    Corsair TX650W PSU

  3. #3
    Join Date
    Sep 2008
    Location
    Canberra, Australia
    Posts
    206

    Default Re: Second Screen no long working?

    this is because you're using the 4870X2... this is basically like using 2 4870s in CrossfireX, and dual monitors are not fully supported by CF yet... first of all, get rid of all of your Catalyst drivers, then install the newest revision available right now (8.9 -> AMD GAME Drivers & Tools).

    This isn't fully supported by the 8.9 drivers yet, but should run better than before. If you ensure that you have both monitors connected when you startup and then switch straight to extended desktop (or clone mode) you shouldn't have a problem, until you start running a full screen application. Check the release notes for version 8.9 under "Known Issues with Windows Vista OS" for more information about the errors.

    EDIT: Are you using DVI (if so what type?) or HDMI to connected your monitors?
    NZXT Lexa BlackLine Case with Red LEDs
    Corsair TX-750 Modular PSU
    Gigabyte EP45-DS3P (BIOS F7)
    Intel Core 2 Quad Q9300 @ 3.73GHz (downclocked for the summer )
    OCZ Vendetta 2 CPU Heatsink
    2x 2GB Kingston HyperX RAM PC2-6400 @ 996MHz (4-5-5-15)
    3x Seagate Barracuda 7200.11 500GB HDD in RAID5
    2x HIS Radeon HD 4850 @ 745/1090 in CrossFireX
    2x ThermalTake DuOrb GPU Heatsink
    D-Link Super G PCI WLAN Adapter
    Asus Lightscribe 20x SATA II DVD-DL Burner
    Creative X-Fi XtremeGamer Fatal1ty Pro
    2x 22" LG W2252TQ-PF Widescreen LCD Monitor (YAY!! Finally got the second one!!)

  4. #4
    Join Date
    Sep 2008
    Posts
    5

    Default Re: Second Screen no long working?

    The thing is I have already tried removing all the traces of drivers by doing a complete format and directly installing the catalyist 8.9 drivers. I go to the CCC control panel, want to enable to second screen, ( which shows default monitor even though its plugged in or not ) and it looks like it enabling it, but greys it out right away. So I can't set any resolutions or anything, it just won't enable it. The weird thing is that normally even though I had nothing installed the TV would also show up on post, which now it doesn't anymore

    Im using a normal DVI to DVI for my working LCD 19" and the TV which doesn't work anymore is hooked up with a DVI to HDMI converter hooked to a HDMI cable. Hope someone figures this one out, im going crazy :S

    EDIT:
    Isn't there a way I could see if the monitor is even being found? Right now it's saying there is a second monitor in the windows display properties and Catalyst, but somehow it won't let me enable it. Normally when switching channels on my TV to the channel where the HDMI is plugged in the 19" monitor would flicker for a second, it doesn't do that anymore either. This leads me thinking it might actually be the cable, which I still find strange...
    Last edited by damunk; 10-06-2008 at 07:24 PM.

  5. #5
    Join Date
    Sep 2008
    Location
    Canberra, Australia
    Posts
    206

    Default Re: Second Screen no long working?

    are you trying to enable extended desktop or just the TV... try changing the output to the TV by itself, or even try unplugging the monitor altogether. If the TV shows up in CCC then you can be sure the PC is recognising something is connected. This means that the HDMI output is ok, but it may not be reaching the TV. This means that it could be the cable or the input on the TV. Try connecting your TV by some other means if you can (S-Video or RCA/Composite should be no problem)
    NZXT Lexa BlackLine Case with Red LEDs
    Corsair TX-750 Modular PSU
    Gigabyte EP45-DS3P (BIOS F7)
    Intel Core 2 Quad Q9300 @ 3.73GHz (downclocked for the summer )
    OCZ Vendetta 2 CPU Heatsink
    2x 2GB Kingston HyperX RAM PC2-6400 @ 996MHz (4-5-5-15)
    3x Seagate Barracuda 7200.11 500GB HDD in RAID5
    2x HIS Radeon HD 4850 @ 745/1090 in CrossFireX
    2x ThermalTake DuOrb GPU Heatsink
    D-Link Super G PCI WLAN Adapter
    Asus Lightscribe 20x SATA II DVD-DL Burner
    Creative X-Fi XtremeGamer Fatal1ty Pro
    2x 22" LG W2252TQ-PF Widescreen LCD Monitor (YAY!! Finally got the second one!!)

  6. #6
    Join Date
    Sep 2008
    Posts
    5

    Default Re: Second Screen no long working?

    It seems to be the HDMI connector on the TV... Ive plugged it into a different slot and all of a sudden it got recognised.. You think the connector is broken? This seems really odd to me since I haven't touched it in weeks and if anything shouldve broke it shouldve been the dongle since thats the only thing that has been moved around.

    It was quite an expensive TV and I haven't had it for longer than half a year.. So if 1 of my 2 HDMI connectors already broke I'm seriously thinking about returning it before the warranty expires. I have no other HDMI device right now to test it with so I can't really say if its broken, but why else would it not show up on the HDMI port?

  7. #7
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Second Screen no long working?

    A new TV before the warranty expires is always nice, if you can afford the shipping.

    If not, it may have just been a loose connection, or dusty maybe?

  8. #8
    Join Date
    Sep 2008
    Location
    Canberra, Australia
    Posts
    206

    Default Re: Second Screen no long working?

    did you use the other HDMI input or a different interface altogether? if it all of a sudden started working when you used the other HDMI port then you know that its the port itself, if you used a different interface because neither of the HDMI inputs were working then it could be the HDMI controller
    NZXT Lexa BlackLine Case with Red LEDs
    Corsair TX-750 Modular PSU
    Gigabyte EP45-DS3P (BIOS F7)
    Intel Core 2 Quad Q9300 @ 3.73GHz (downclocked for the summer )
    OCZ Vendetta 2 CPU Heatsink
    2x 2GB Kingston HyperX RAM PC2-6400 @ 996MHz (4-5-5-15)
    3x Seagate Barracuda 7200.11 500GB HDD in RAID5
    2x HIS Radeon HD 4850 @ 745/1090 in CrossFireX
    2x ThermalTake DuOrb GPU Heatsink
    D-Link Super G PCI WLAN Adapter
    Asus Lightscribe 20x SATA II DVD-DL Burner
    Creative X-Fi XtremeGamer Fatal1ty Pro
    2x 22" LG W2252TQ-PF Widescreen LCD Monitor (YAY!! Finally got the second one!!)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •