Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Help with my xfx hd5770 ...... please




  1. #1
    Join Date
    May 2010
    Location
    stoke on trent
    Posts
    5

    Default Help with my xfx hd5770 ...... please

    After lots n lots of browsing for solutions i finally found this place, i know where have i been... lol.

    Ill start with my rig, its old so........... lol

    42" panasonic viera
    xfx hd 5770
    Hitchi 500gb hd
    800w psu
    Crappy Biostar gf5070v-m7 m/b
    Crappy Intel Pentium D 945 running at 3.7ghz (800fsb...lol)
    4gb of 800mhz samsung ram (not dual core)
    Windows 7 ultimate 64 bit

    basically my concern is that i have just bought an xfx hd5770 and i know for a fact that it isnt running as fast as it should, for starters im only averaging 25fps in multiplayer with Trackmania in multiplayer where as my old sapphire 1950x pro ran the game at around 50fps on a 42" plasma ....... It just seems like every game i try to play is holding back and stuttering. I do know that some of my hardware is perhaps holding the card back a bit but not this much surely ?

    Im not too good on techy stuff so i joined here with the hope that someone could help me out. I have just got that little programme called cpu-s and gpu-z to see if that can tell me anything and i was quite shocked to be honest with you.

    Running cpu-z it states that my hd 5770 card has a Core speed of 157mhz and memory of 300mhz ....... wtf ?

    Unfortunately my motherboard doesnt run in pci-e 2.0 mode because its that dated and my processor is the same but i wouldnt have thought that it would make my graphics card play up as much as this.

    Basically i think i must have something set wrong somewhere and i am really tired of searching for a solution, could one of you guys please help me sort this out... Either im stuck or i need one massive upgrade ........ oh no :(

    Thanks all

    Buster
    Last edited by OatcakeBuster; 05-24-2010 at 12:20 AM.

  2. #2
    Join Date
    Apr 2009
    Location
    Virginia
    Posts
    1,470

    Default Re: Help with my xfx hd5770 ...... please

    You may want to go to control panel add and remove programs, and uninstall all the ati software. Use the ATI software uninstaller. Then when it reboots allow windows to search for new drivers. You also may need a bios update for the motherboard. Be sure your intel inf files are up to date also.
    Last edited by artdrivers; 05-24-2010 at 08:35 AM.
    http://forums.tweaktown.com/gigabyte...ench-test.html
    http://www.gigabyte-usa.com/FileList...ios_qflash.pdf
    Phenom II 945 @ 3.2Ghz w/Thermaltake Big Typhoon Pro 14 CPU Cooler
    Gigabyte GA-MA78GM-S2H rev.1.1 F11
    Sapphire 3870HD / 100225L / 512MB / ddr4
    4GB / Kingston / KHX8500D2K2/2GN / 5-5-5-18 / 1066Mhz
    (2) WD Caviar / WD2500AAKS/ 250GB in SATA RAID-0
    (1) WD Caviar / WD2500AAKS/ 250GB in SATA AHCI
    (2) IDE's 1 8XdualDVDRW 1 52x32x52x CDRW
    Antec /Neo HE550 / 550W
    Mid size ATX case with show through panel
    2) 80x80 front fans (1) 120x120 rear fan and small nb fan
    Microsoft comfort curve USB keyboard 2000 ver.1.0
    Logitech G500 USB mouse
    Monitor: CMV937A
    7.1+2 Channel High Definition ALC889A
    Dual boot Windows 7 32bit home & Windows 7 64bit home


  3. #3
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Help with my xfx hd5770 ...... please

    The core/memory speeds you state are normal, this is 2D mode and powerplay in action, to keep things cool.

    Once you start anything graphical it will increase to where it should be.

    Can you please post a image of GPU-z, maybe your card is not running at x16
    GPU-Z Video card GPU Information Utility

    You are right, even though your board can't do PCIE 2.0, this card should at least run better than you older one. Maybe this causes an issue though, not sure?

    Might need a new board?

    Is this the board?
    BIOSTAR :: 945GC-M7 TE :: Specification

  4. #4
    Join Date
    May 2010
    Location
    stoke on trent
    Posts
    5

    Default Re: Help with my xfx hd5770 ...... please

    Thats the thing, the card doesnt seem to be kicking in at all, it struggles like hell to play Trackmania.......

    Your right though, i may try and update my bios to see if that will solve anything but i wouldnt have thought it will. Every game is really stuttering with slow frame rates, maybe all of my hardware is just too outdated for the card ?

    Here is what my gpuz shows, my motherboard is a crappy GF7050V-M7




    Thanks guys

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Help with my xfx hd5770 ...... please

    Well it is running at x16, so that's not the issue.

    Maybe it is just the rest of the system can't handle it

  6. #6
    Join Date
    Apr 2009
    Location
    Virginia
    Posts
    1,470

    Default Re: Help with my xfx hd5770 ...... please

    You may just have a bad video card. Quickly RMA it. The sooner the better. Consider the facts, the old card worked fine. You are suppose to be upgrading video cards. Not downgrading. Although you are changing from a 256bit Bus width card to a 128bit Bus width card. The transfer rate (fps) should still be close to the same. Due to the shaders and other technologies of the newer card.
    Last edited by artdrivers; 05-27-2010 at 08:27 AM.
    http://forums.tweaktown.com/gigabyte...ench-test.html
    http://www.gigabyte-usa.com/FileList...ios_qflash.pdf
    Phenom II 945 @ 3.2Ghz w/Thermaltake Big Typhoon Pro 14 CPU Cooler
    Gigabyte GA-MA78GM-S2H rev.1.1 F11
    Sapphire 3870HD / 100225L / 512MB / ddr4
    4GB / Kingston / KHX8500D2K2/2GN / 5-5-5-18 / 1066Mhz
    (2) WD Caviar / WD2500AAKS/ 250GB in SATA RAID-0
    (1) WD Caviar / WD2500AAKS/ 250GB in SATA AHCI
    (2) IDE's 1 8XdualDVDRW 1 52x32x52x CDRW
    Antec /Neo HE550 / 550W
    Mid size ATX case with show through panel
    2) 80x80 front fans (1) 120x120 rear fan and small nb fan
    Microsoft comfort curve USB keyboard 2000 ver.1.0
    Logitech G500 USB mouse
    Monitor: CMV937A
    7.1+2 Channel High Definition ALC889A
    Dual boot Windows 7 32bit home & Windows 7 64bit home


  7. #7
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Help with my xfx hd5770 ...... please

    I would also test the card in another system if you can before you decide to send it off, just in case it isn't the card itself

  8. #8
    Join Date
    May 2010
    Location
    stoke on trent
    Posts
    5

    Default Re: Help with my xfx hd5770 ...... please

    Well this is the story of my "upgrade"

    I basically have a system that isnt by anymeans over powering but its served me well whilst it was on windows xp. It ran my old x1950 pro with no issues what so ever with good frame rates. However since trying to move over to hdmi (hd5770) from x1950pro dvi, i thought id format my system and install windows 7 whilst i was at it. Once i had installed Windows 7 i have had nothing but trouble with every graphics card i have tried to install. I Borrowed a hd4650 from a friend that was supposed to last me untill i could afford my hd5770 but his card did exactly the same thing, i just thought it wasnt a very good card for playing games on but it works flawlessley in his quad core system with excellent frame rates, however i have not tried my new hd5770 in his machine to check it isnt the card. Personally i know the card is fine but what i want to know is why my computer isnt good enough to run the newer cards, could it possibly be something to do with the direct x compatabilitys of my motherboards spec ? The chipset is really old, my ram is old and lets face it the processor is crap too.
    Please be honest with me because im upgrading my whole system if i need to. Im currently looking into buying a q9400 and 2x pci-e 2.0 gygabyte m/b . I would kinda like to know aswell what ram would be sufficient. I think a system based around the above should be more than up to date without spending i7 money :)

    Thanks guys, i appreciate your time and your help.
    Cheers
    Buster

  9. #9
    Join Date
    Sep 2002
    Location
    Central Alberta , Canada
    Posts
    1,019

    Default Re: Help with my xfx hd5770 ...... please

    Although your current system is no where near "high end" by todays standards you should still be seeing pretty much at least as good of frame rates as you did with Windows XP. Were you able to find and install drivers for all of your other components for Windows 7? Just wondering if the problem lies in chipset drivers rather than the video card.
    Antec 900 case (4 120mm and 1 200mm lighted fans + UFO flashing light set + 2 12" and 1 6" Mutant Mods meteor lights) - Aerogate ll thermal controller - Asus M2N-e SLI - AMD 64 X2 AM2 6400+ - Corsair TX650 PSU - MSI 450GTS Cyclone OC - 2 X 2GB Patriot Extreme Performance PC2 6400 RAM - SATA 320 GB Seagate HD, SATA 300GB Maxtor HD and IDE 80 GB Samsung HD - Floppy Drive/Card Reader Combo - LG SuperMulti Lightscribe 18x DVD RW - Plextor PX-716A DVD r/rw - Windows 7 Home Premium 64

    Crude but Effective ... it is a way of life.

  10. #10
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Help with my xfx hd5770 ...... please

    I think it is a very old chipset, and a old CPU as well, both very well could be bottle-necking the card due to how fast it runs and or causing various related issues with it.

    I would look into a P35 or P45 board, do not get a model with "L" in the name as they are cheap. If you are seriously looking I would check out P45-UD3R or find a good used EP35-DS3R on ebay, of course any models above those would be great too (UD4/UD4P/UD5/DQ6)

    As for CPU, you can normally find a used 8400 on ebay for $80-100, and if you wanted cheaper you could maybe look at the 7400/7500's. Of course the quad you mention would be good too, I was just thinking of other options for you that might not be as much $$

    Your current memory may be ok, not sure? Can you show me a image of CPU-z SPD tab

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •