I give up so im asking for help. I can't get a mic to work on my new computer. Sound DOES work.
Board- Asrock 870 Extreme 3, geforce 8800 gtx, amd phenon x2, 4gigs ram(2x2).

Tried both Front and Back Mic panels. Sound works for both front and back panels.
I tested the mic in all cases using Recording Device settings, (watching the level indicator), and ventrillo. I tested using 2 different headsets that both work on another computer. I tested in Windows 7 64 bit , windows 7 32 bit, and in Ubuntu. Sound worked in all cases but no mic. Latest direct x, tried tons of other drivers chipset for example, tried a bunch of BIOS options and updated to latest bios. Tried disabling the onboard audio in bios, tried disabling / unplugging the front panel audio, tried disabling and enabling every recording device in the audio manager, tried to Mic boost / mic boost +30, tried listening to it, tried changing the sampling rate, tried raising its volume / muting it / unmuting. Tried removing one of my 2, 2 gig ram sticks, tried changing their slots.

I tried Three different drivers the autoinstalled ones from windows 7 64x, then the ones from the Asrock Cd, and then the latest ones from realtek website.

Second I took the soundcard from my old computer (which works), creative live gamer, latest drivers from website, hooked up front panel, sound works mic levels wont move.

For a third and final attempt i bought a USB headset adaptor, and again the sound worked but not the mic. Anyone any ideas? im so stuck.