Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Raidmax Cobra case, Side fan LED lights up but fan doesnt spin




  1. #1
    Join Date
    Aug 2004
    Posts
    1

    Default Raidmax Cobra case, Side fan LED lights up but fan doesnt spin

    I recently bought a new case the Raidmax cobra premodded case. On putting it together everything works, except I cant get the side fan to work. The LED on the fan lights up when I turn the PC on and the fan twitches, but does not spin. The fan itself has a male and female power connector and I have tried various methods of plugging them into places but cant get it to work (bit of a n00b), any help?

    Charlie.

  2. #2
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default Re: Raidmax Cobra case, Side fan LED lights up but fan doesnt spin

    Since the fan moves just a bit and the LED works fine, you already know you're getting power to it. Also considering that fan uses a standard Molex connector for power, there are no tricks to getting it to work. THe fan is just defective. You might check out where you bought it from and see if they'll swap you out for a good fan, but make sure you get the same colors as this is one of the things that makes that case look so good.
    Old age and treachery will overcome youth and skill
    My Toys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •