Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: northbridge chipset




  1. #1
    Join Date
    Oct 2005
    Posts
    2

    Default northbridge chipset

    my heatsink came loose from my northbridge chipset, im sure that is not a good thing, but i would like to know what the possible causes are? here is some info about my cpu:

    AMD Athlon 64 3300+
    AsusTek K8S-LA Salmon motherboard
    sis 760 chipset
    southbridge sis 964
    phoenix technoligies bios ver 3.14
    512 MB DDR Ram
    Windows Xp Home with Service PAck 2 build 2600
    Direct X 9.0c

    if you need more info let me know, any help would be greatly appreciated.

  2. #2
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default Re: northbridge chipset

    Who can really say why it came off. It could have been a poor adhesive batch used at the factory during creation or it could have been something that happned to the board during transit to your retailer. If the heatsink has plastic push-pins, make sure they are still serviceable and reinstall the sink. If it is secured in place by an adhesive, then look for some thermal adhesive that is designed for this type of application. Arctic Silver has had some out for years that has shown to be an effective glue as well as a workable thermal interface material.
    Old age and treachery will overcome youth and skill
    My Toys

  3. #3
    Join Date
    Oct 2005
    Posts
    2

    Default Re: northbridge chipset

    thanks for you advice, ill check it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •