Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: VIA Hyperion Driver Guide / FAQ




  1. #1
    Join Date
    Jul 2002
    Location
    Canberra, Australia
    Posts
    1,158

    Default

    VIA HYPERION DRIVER GUIDE/FAQ

    Note: The 4.50 Hyperions are reported to cause Delayed Write Failure (hard drive corruption) when installed. It is strongly recommended that you do not install these drivers. VIA has released a new version 4.51 which is supposed to fix this problem.

    [Updated for Hyperion 4.51. Much of the following information is sourced from: The Official VIA Hyperion Driver Installation Guide]


    What Are The VIA Hyperion Drivers? - The VIA Hyperions were introduced on 6th December 2002. Before that time, VIA developed a driver package named the "VIA 4in1 drivers" which was essentially the same package of drivers. The VIA Hyperion 4in1 drivers continue that tradition, and have retained the version naming sequence, starting at version 4.45. Gradually the "4in1" part is being dropped and they are now simply referred to as the "Hyperions".


    Which Drivers Are In The Hyperion Package? - Just like the 4in1 driver package, the Hyperion includes four system drivers to improve the performance and stability of systems using VIA chipsets - especially the latest PT800 and KT600 VIA chipsets.


    What Do The VIA Hyperion Drivers Each Do? - The Hyperion package automatically detects your operating system and will install only what is necessary. The four drivers have the following function:

    VIA Registry (INF) Driver - Enables the VIA Power Management function. Installed on Win98/ME, Win2K, WinXP.

    VIA AGP Vxd Driver - Provides service routines to your VGA driver and interface directly to hardware, providing fast graphical access. Installed on Win98/ME, Win2K, WinXP.

    VIA IDE Filter driver - Enables the performance enhancing bus mastering functions on ATA-capable Hard Disk Drives and ensures IDE device compatibility. (Also known as the ATAPI Vendor Support Driver). Installed on Win98/ME, Win2K, WinXP.

    VIA PCI IRQ Miniport Driver - Sets the system's PCI IRQ routing sequence for Win98 only.

    VIA IDE Bus Master Driver - Enables performance enhancing bus mastering functions for WinNT only.


    Do I Have To Install The Latest Version of The VIA Hyperions? - The short answer is no, you don't have to install the latest Hyperion drivers (4.51 4in1s) unless you have a very recent VIA chipset (like the PT800, KT600 or newer) - in which case yes you should definitely upgrade, both for added performance and greater stability. If you're using Windows XP, it already has the 4.35 version of the old 4in1 drivers built in and will install them when it detects your VIA motherboard. This XP default version should work just fine with all but the latest VIA motherboards. However each newer version of the Hyperion drivers may contain fixes for particular applications and games, so if you're having problems running a program with older 4in1s then it may be necessary to update your VIA drivers.

    Note: that VIA themselves recommend that since Win95/98/98SE are now relatively old operating systems, the Hyperions are no longer optimized for those operating systems. They recommend that users of VIA chipsets who run Win95/98/98SE use an older version of the 4in1s, such as version 4.35.

    How Do I Install The Hyperions Correctly? - This is incredibly simple. Download the driver package into an empty folder. Run the executable and follow the prompts. For most users select "Quick install" and it will not prompt you for which drivers to install/uninstall - it will simply install the correct drivers for your system. For advanced users select "Normal Install" and manually choose which drivers you want to install/uninstall. Once the drivers are installed, reboot your machine as requested and the drivers are now updated.

    That's it. There's no trickery required. It is very important that you don't run the Hyperion package in Win2K Compatibility Mode or in Safe Mode, as this can result in the wrong drivers being installed for your system.

    If you get an error like "Windows can't run 16bit program" when trying to run the driver package then don't panic. Simply reboot your machine and the package should run fine the next time you try. This is not a compatibility problem, just a problem with the temp files when the package first unzips itself.

    The Hyperions should be the only VIA drivers you need to install.


    How Do I Check The VIA Driver Versions On My System? - If you want to check whether the components of the Hyperion package have installed correctly, whether you have the latest driver versions, or if you just want to manually update individual devices, do the following:

    Hyperion/4in1 Version:
    To check which version of the Hyperions/4in1s you have installed, go to Start>Run and type "Regedit" (without quotes). Expand the HKEY_LOCAL_MACHINE key (click the + next to it). Expand the SOFTWARE Key and scroll down to the Via4in1Driver folder and click on it. You should see an entry called "4in1 Version" with the version number next to it (e.g. 4.51 for the Hyperions). The Viamach entry refers to the INF Driver version (2.00 is the latest).

    Individual Device Checking/Updating
    To check and/or update individual devices, go into Control Panel>System>Hardware>Device Manager. Then check the following devices by right clicking on each, selecting Properties>Driver. Versions shown below are for the latest Hyperions under WinXP with SP1:


    Provider for all: VIA Technologies, Inc.

    IDE Filter Driver
    IDE ATA/ATAPI controllers> VIA Bus Master IDE Controller
    Version: 5.1.2600.120 (<--- Version 1.20a)

    AGP Driver
    System Devices> VIA CPU to AGP Controller
    Version: 5.1.0.3442 (<--- Version 4.42)

    INF Driver
    System Devices> VIA Standard CPU to PCI Bridge
    Version: 5.1.0.200 (<--- Version 2.00)


    Note: You may see slightly different version numbers. You should only really take note of the last few digits of the driver to see the driver's version.

    If you've installed the Hyperion Drivers as advised and your versions don't appear to be updated for your OS (e.g. the provider is listed as Microsoft or the last 3 numbers are different) then you can update each device manually by doing the following:

    1. Manually unzip the Hyperion Driver package. Even if the package is an .exe file, you can extract the contents using Winzip. Simply run Winzip, choose Open and point it to the Hyperion .exe file, and extract the contents to an empty folder.

    2. Go to the relevant device in Device Manager (see above) then choose Update Driver>"Install from a list or specific location">"Don't search, I will choose the driver to install">Have Disk and manually point Windows to the folder where you unzipped the package. You may have to find a subfolder with the correct driver .inf file (e.g. the IDEWinXP Folder).

    3. Reboot as requested and check the driver version. It should be updated now.


    Note: The latest Official VIA drivers can be downloaded from VIA Arena the Official VIA Support Site

    Older (and beta) versions of the 4in1s are available at Guru3D.


    What About Other VIA Drivers - Do I Need Them? - You should only need to install the Hyperions. However if your system is still having problems, try the following advice:

    - Don't install the 3014 Miniport drivers. They are not necessary for most systems. If your system identifies your IDE drives as SCSI, or you have a long black screen on loadup, then you've installed these drivers. Go into Add/Remove programs and remove them.

    - Don't install the AGP Drivers separately, as the latest version of these is contained in the new Hyperion package and is installed as part of that package. Don't try to install older versions of the AGP Driver over the newer Hyperions.

    - If you're experiencing problems with audio crackling or poor performance, try the Latency Patch v0.19 or beta version 0.20. You can download this directly from the patch author George E Breese's Site. George also has a Creative SoundBlaster/Audigy soundcard patch which should reduce any audio crackling with these cards on a VIA chipset. Check it out here.

    - If you're running Windows XP (Home or Pro), it is highly recommended that you check out my comprehensive WinXP Tweak Guides at TweakTown - WinXP Tweaking: From Reformat to Relax and WinXP Tweaking: From Relax to Righteous. Also check my System Optimization Guide, because in almost every case I've seen, what people think are problems caused by VIA Drivers are actually general system optimization issues, so make sure you follow the tweak guides first before blaming the drivers.

    Keep coming back as I update this guide.

    - Koroush Ghazi

  2. #2
    Join Date
    Nov 2001
    Location
    Taipei, Taiwan
    Posts
    4,308

    Default

    Nice guide :)
    Cameron "Mr.Tweak" Wilmot
    Managing Director
    Tweak Town Pty Ltd

  3. #3
    Join Date
    Aug 2002
    Location
    Ohio, USA
    Posts
    1,296

    Default

    Nice reference post. Thanks.

  4. #4
    Join Date
    Sep 2002
    Posts
    2

    Default

    Great XP Guide,Thank-You so much. Easily the best guide I've seen.
    :-) Dave

  5. #5
    Join Date
    Nov 2001
    Location
    New England Highlands, Australia
    Posts
    21,907

    Default

    But it should have been a sticky so I'll fix that. ;)


  6. #6
    Join Date
    Oct 2002
    Posts
    1

    Default

    hi, i've unzipped the 4in1 but every time i try to install it, my screen freezes. my cam has only worked a few min here and there over the past few weeks. i put in a usb bypass card a couple days ago and cam worked but when i rebooted, it wouldnt. why wont the 4in1 install? and now that i have bypass card should i remove it to try 4in1 again? i dont know a lot about computers, nothing basically lol so if anyone responds to this, please speak plainly. I've been in logitech's site, over and over, and tried so many things. What i dont understand is, why has my cam worked for a few months and all of a sudden this problem. my OS is Win98SE. ty

  7. #7
    Join Date
    Jul 2002
    Location
    Canberra, Australia
    Posts
    1,158

    Default

    I'm not sure what a USB Bypass card is...I assume you mean a card which allows several USB ports to come off one USB port? Anyway, quite obviously once you installed this card and hooked up your cam through it the problems began, so pull out the bypass card and disconnect the cam from any USB ports.

    Next install the 4-in-1s by running the .exe file that comes in the package. Then reboot and try to manually update the devices that haven't updated by themselves (instructions above and in the "4-in-1 install problem" thread on this forum.

    Then when everything looks OK, reinstall your bypass card and camera and everything should work.

    It may well be your camera is also faulty and causes lockups in Windows, but try the above first before coming to that conclusion.

    Also, try the Via Arena Drivers Page, there's a USB patch for the KT266 chipset (if that's what you're running.

  8. #8

    Default

    Insalling the Via 4in1 Under XP At compatabillity tab for the installer set to win2000 it will install devices hidden by XP you will probably notice a slight performance increase too
    Visit my photochopped car site at

    ZTi

    INTERCEPTOR-XIV (so called because its the 14th incarnation duh) Consists of ;

    AMD Athlon XP 1600+/1400Mhz @ 1900+/1575Mhz (150Mhz FSB 1.750v)
    Jetway V333DA A KT333 Award Bios Revision A04 (VIA 4in1 4.43)
    A-Data 256MB DDR PC2100 (2.6v DIMM)
    ST Labs GeForce4 MX 440 64 MB DDR @ 285/435 (1.6v Detonator 40.72)
    VIA AC'97 Enhanced Audio (On Board)
    350W Eagle P4 Certified PSU
    80G Seagate Barracuda IV ST380021A 7200
    40G Western Digital Caviar WD400BB-32CLBO 7200
    10G Seagate U Series V ST310211A 5400
    MSI 48x16x48 CD/RW
    Banksia Wave SP 56 Dual PnP (External)
    3Com 10/100 NIC (Only Installed When Needed)
    Logitech cordless Freedom Optical Mouse, Keyboard and Wingman Game PAD
    WINXP PRO + SP1 300+Apps installed 120 odd Games Minor Glitches Occationally (Due to the 120MB Registry I guess) 3D Mark 6306

  9. #9
    Join Date
    Jul 2002
    Location
    Canberra, Australia
    Posts
    1,158

    Default

    Firstly, installing a major device driver using compatibility mode is a no-no. You are basically telling your 4-in-1 driver that you're running Win2000 when you're running XP, and this is not recommended. It could result in problems.

    I'm not sure which which "hidden devices" will be installed, as I already mention the relevant individual devices and how to check and update each one manually should you want to do that. If you look at the VIA installation guide, you'll see at the bottom that in theory the same device drivers are installed for both XP and 2000.

    In any case, I've installed the 4-in-1s using compatibility mode (just to see what it does) and I found that in fact it may not install certain device drivers, and of course there is no "performance improvement".

    However if people feel the need to experiment, you can do so, just make sure you create a system restore point or backup before hand. I think you'll find that a lot of people are making the installation of 4-in-1s a lot more complex than they should be. Just follow my tips in the first post and it'll all go smoothly.

  10. #10
    Join Date
    Dec 2002
    Posts
    2

    Default

    az11ea motherboard,kt133a chipset,40gig hd,512ram,cnr modem,ati rage128,10/100linksys
    i have 2 onboard usb ports (backside) and a socket (pins) for 2 more (listed as frontside)..can't find a cable for this....also wanting to know if i can install new 4in1 drivers on this machine...
    problem originated by trying to install logitech webcam(usb) to a belkin 4 port hub...mouse is usb w/pc2 adapter,other imaging device(hp all in one scanner,printer,copier) has been disabled...still won't accept quick cam driver...hub is carrying photosmart card reader with no problems...2 way sat has other onboard port...will installing the cable for the frontside usb ports solve this?? logitechs site seems to lead me to usb problems...

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •