Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: A10 7850K running hot at new build




  1. #1
    bluebamboo is offline Junior Member
    Join Date
    Jun 2015
    Location
    Kansas
    Posts
    2

    Question A10 7850K running hot at new build

    Hello tweaktown, newbie here and I wanted to seek some advice on my 1st build. I got wonderful advice by browsing the forum when building my first desktop, so a big THANK YOU first to all the contributors! Here goes my problem and some solution I've found online, and I definitely need your advice on how the following might work out, before I crash anything!

    Problem:
    APU and mobo running hot in BIOS, without booting OS. HWmonitor shows APU at ~64C and mobo ~40C. This is much higher than what I expected and what most tutorials have recommended.

    Part specs:
    CPU: AMD A10 7850K
    MOBO: Asrock FM2A88M Extreme4+ mATX, no OC, BIOS v2.4
    SSD: Crucial MX100 256G
    HDD: Seagate 1TB 7200 RPM 64MB Cache SATA 6.0
    RAM: HyperX 2x8GB DDR3 1600
    PSU: Used, Cooler Master 360W 12V V2.3
    Fans: 1 fan mounted on the case, CPU stock fan
    Case: Used, some Cooler Master ATX model

    Possible reasons, with some potential solutions:
    1. PSU is not good enough. It comes with the CM case and my bf has used them for 1.5 years for his entry-level gaming build, so potentially it's getting old, plus the wattage seems a bit low to me.
    SOLUTION: Get a newer and better PSU at 400+ watt.

    2. Stock APU cooler is too weak or not installed properly.
    SOLUTION: Reinstall the stock cooler and consider buying an aftermarket CPU cooler.

    3. Not enough case fans or bad airflow in the case. There is only 1 120mm rear fan on the case.
    SOLUTION: Better cable management; clearing the dust in the fan and adding a front fan to create better airflow.

    4. Asrock mobo issues. I have read elsewhere that they tend to overheat.
    SOLUTION: Return it...

    5. HWmonitor not reporting the actual temperature. However, the airflow from the CPU cooler does feel a bit warm. Many people have suggested AMD Overdrive for exact temperature reading, but I want to make sure that overheat won't cause problem for OS install before using AOD.

    6. BIOS problems. Yesterday the screen stuck at a failed 2.6 BIOS flash and I had to shut down and clear CMOS. Turns out that maybe I don't need to flash it since 2.4 might already be compatible with Kaveri...so I just kept the stock BIOS and then noticed the overheat. I didn't pay attention to the temperature reading before the flash so it's hard to compare.

    7. Other compatibility and/or setup issues.

    Suggestions on the plan of attack? Any input are much appreciated!

  2. #2
    bluebamboo is offline Junior Member
    Join Date
    Jun 2015
    Location
    Kansas
    Posts
    2

    Default Re: A10 7850K running hot at new build

    Just an update:

    I've put on a Cooler Master Hyper 212 Evo (as suggested by many people) and CPU temperature is now around 44 C. Turns out that APU tends to heat easily so better cooling is needed and stock fan seems not enough. Now off to booting the OS :)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •