Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 8 of 8

Thread: Ripsaw Z-series not showing up as quad channel




  1. #1
    havasuphto is offline Junior Member
    Join Date
    Jan 2013
    Location
    Lake Havasu City, AZ
    Posts
    34

    Default Ripsaw Z-series not showing up as quad channel

    I bought this memory;Newegg.com - G.SKILL Ripjaws Z Series 32GB (8 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9Q2-32GBZL
    Because in the description it said it was quad channel capable. I have an asrock OC formula Z77 motherboard, and an Intel i7 3770K cpu. In the bios I have xmp version 1.3 enabled, and it correctly identifies the speed of the ram(1866). however, when I check the ram in Cpuiz, it says "dual channel". I checked with some other software and it also identifies the ram as dual channel.
    So, what am I missing here? why is my quad channel ram not showing up as that?

  2. #2
    wismean95 is offline Junior Member
    Join Date
    Sep 2012
    Location
    Australia
    Posts
    18

    Default Re: Ripsaw Z-series not showing up as quad channel

    Because Z77 CPUs and Motherboards don't support quad channel RAM. That is one of the main selling points of the X79 CPUs. So unfortunately, while you have a 3770K, your RAM will run in dual channel
    Last edited by wismean95; 01-27-2013 at 09:45 AM. Reason: missed a sentence

  3. #3
    havasuphto is offline Junior Member
    Join Date
    Jan 2013
    Location
    Lake Havasu City, AZ
    Posts
    34

    Default Re: Ripsaw Z-series not showing up as quad channel

    Quote Originally Posted by wismean95 View Post
    Because Z77 CPUs and Motherboards don't support quad channel RAM. That is one of the main selling points of the X79 CPUs. So unfortunately, while you have a 3770K, your RAM will run in dual channel
    Well I missed that little fact. I guess I return these then, since they were more expensive than dual channel. bummer.

  4. #4
    wismean95 is offline Junior Member
    Join Date
    Sep 2012
    Location
    Australia
    Posts
    18

    Default Re: Ripsaw Z-series not showing up as quad channel

    Quad channel doesn't provide a noticeable difference anyway (the performance is beyond the point where it is needed or used) unless you run extreme editing programs so its a bit of a waste of money anyway.

  5. #5
    havasuphto is offline Junior Member
    Join Date
    Jan 2013
    Location
    Lake Havasu City, AZ
    Posts
    34

    Default Re: Ripsaw Z-series not showing up as quad channel

    Quote Originally Posted by wismean95 View Post
    Quad channel doesn't provide a noticeable difference anyway (the performance is beyond the point where it is needed or used) unless you run extreme editing programs so its a bit of a waste of money anyway.
    What do you define as an extreme editing program? I do edit HD video with Avid Studio and Avid Media Composer. But, i think there really just isn't that much difference/improvement. Just wished I noticed it said X79...that would have been my clue. the price difference was only about $15, and they are going to charge me a restocking fee higher than that-so I'll just keep them, and maybe OC them.

  6. #6
    wismean95 is offline Junior Member
    Join Date
    Sep 2012
    Location
    Australia
    Posts
    18

    Default Re: Ripsaw Z-series not showing up as quad channel

    I meant running multiple instances of things like 4k videos or 21Mp photos and stuff in photoshop or premiere etc. That stuff chews RAM and thats where the memory clock counts
    Last edited by wismean95; 01-27-2013 at 10:07 AM. Reason: forgot a bit

  7. #7
    havasuphto is offline Junior Member
    Join Date
    Jan 2013
    Location
    Lake Havasu City, AZ
    Posts
    34

    Default Re: Ripsaw Z-series not showing up as quad channel

    Alright. I'm not into editing 4K video's, and don't really do much photo editing anymore. Just do 1080P/60/30/24. So I really don't think it's going to matter much.

  8. #8
    Join Date
    Sep 2011
    Location
    Taipei, Taiwan
    Posts
    106

    Default Re: Ripsaw Z-series not showing up as quad channel

    Hi,

    wismean95 is right, you won't feel much difference only if you running lots editing programs/multiple tasks, please note!
    G.Skill Tech Support

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •