Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: GA-P35-S3G usb keyboard issues




  1. #1
    Join Date
    May 2008
    Posts
    7

    Default GA-P35-S3G usb keyboard issues

    I just setup this board and the install went without a hitch. However, my USB keyboard works in the BIOS, but not in Windows. I've tried every USB port and I even see windows find my keyboard (Saitek Eclipse II). I originally had the F2 Bios and upgraded to the F4B bios and still no USB keyboard in Windows. I've tried two different keyboards as well and no luck. Every other USB device I have is functioning correctly. I'm using XP SP3 with 8400 proc & 2GB of Corsair DDR2. (I'm glad I still had my old PS/2 in closet)

    Any help is much appreciated, this is very annoying.

  2. #2
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P35-S3G usb keyboard issues

    Do you have USB keyboard enabled in the BIOS? If not enable it, it is in Integrated Peripherals page

    Other then that The only things I coudl suggest is did you install the keyboard driver itself? I know my Microsoft USB keyboard has it's own driver to be installed.

    One thing I would for sure say you need to install before trying anything else is the Intel Chipset Inf installer >>>
    Download Software, Drivers and Utilities Filters

  3. #3
    Join Date
    May 2008
    Posts
    7

    Default Re: GA-P35-S3G usb keyboard issues

    I tried it with USB keyboard enabled and disabled in the BIOS. I went to Saitek's site and they have no keyboard drivers for the Eclipse 2. I had ran the INF updater from the CD that came with my gigabyte board, but then I ran the gigabyte download manager and it found a newer version than was on CD and installed that. Unfortunately that didn't help. I've even deleted the USB controllers and Human interface devices from Windows and tried rebooting thinking it might redetect and find it.

    The board is even lit up, just none of the keys work at all.

  4. #4
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P35-S3G usb keyboard issues

    Hmmm, do you have any USB storage devices installed? External disks? If not go in that same page I mentioned above and disabled Legacy USB storage Detect and see if that helps. If you do have a external drive, remove it and try with that setting off.

    Other then that I am stumped. PCI-E Locked to 100 and not on AUTO in MIT section?

    Did you install the actual Inf I posted, it is likely a different version then either you mention because for some reason (Which is why I do not install GA linked ones) the GA site is a version or so ahead of Intel. And that does not sound proper to me so I ALWAYS get the Intel one on that page

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P35-S3G usb keyboard issues

    Can you run windows updates (Choose Custom) and see if it find a driver for you? Or open device manager and find the Yellow Checkmark and choose update driver

    Other then that I am out of ideas, you will have to ask here >>>
    http://www.saitekforum.com/forumdisplay.php?f=116

  6. #6
    Join Date
    May 2008
    Posts
    7

    Default Re: GA-P35-S3G usb keyboard issues

    Ran the inf updater you linked, then tried disabling legacy usb devices. The PCI-E was set to Auto so I changed it to 100, but still no luck. The odd thing is the media keys work I can disable the sound from they keyboard but none of the normal keys are working. I also have a logitech wireless that doesn't work.

    I have a another machine sitting behind me that both of theses keyboards work on as well. This other machine dual boots ubuntu and xp and they work in both OS's... So I'm seriously baffled. Kinda bummed I bought a new chip and mb and the board doesn't even recognize my USB keyboard. My previous board was a 965P-DS3 and I used the Saitek keyboard with it no problem.

  7. #7
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P35-S3G usb keyboard issues

    With SP3? Just wondering if it is a SP3 issue

    Did you go to Mirosoft updates and do Custom update? If you need to use another keyboard to get there and start the search, but just quickly plug in the one Saitek and see if it find any drivers related to that. If so, plug back in the old keyboard and install ALL

  8. #8
    Join Date
    Jul 2007
    Location
    Taipei, Taiwan
    Posts
    398

    Default Re: GA-P35-S3G usb keyboard issues

    USB keyboard enabled is for DOS system, I think you will need to install INF driver, so that your windows can search you keyboard, and it can be used.

  9. #9
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: GA-P35-S3G usb keyboard issues

    Hey!

    Glad to see you back!

    He did try several INF driver versions, none worked. I think it is either SP3 issue or something else all together is stopping it.

  10. #10
    Join Date
    May 2008
    Posts
    7

    Default Re: GA-P35-S3G usb keyboard issues

    Quote Originally Posted by Lsdmeasap View Post
    With SP3? Just wondering if it is a SP3 issue

    Did you go to Mirosoft updates and do Custom update? If you need to use another keyboard to get there and start the search, but just quickly plug in the one Saitek and see if it find any drivers related to that. If so, plug back in the old keyboard and install ALL

    Yep its SP3, but this keyboard worked in SP3 with my 965P-DS3. I tried the windows updates, only thing there was .Net under software and drivers for my monitor and printer under hardware.

    This is crazy I can when I remove all my usb devices from device manager and plug the keyboard back in you can see it find a "Saitek Eclipse 2 keyboard" and they board lights up and the multimedia keys work but not anything else.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •