Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: Bug in BIOS prevent booting from USB stick!




  1. #1
    Join Date
    Jun 2008
    Posts
    4

    Exclamation Bug in BIOS prevent booting from USB stick!

    OK, I have found the bug in you F3 BIOS that is causing the problem not able to boot from any USB stick. Here's how you can reproduce it and what is causing it:

    1. I have Enabled ACHI and Disabled IDE controller. I have only SATA HDD and *SATA CDROM* so there's no need for IDE controller! And this is not so uncommon setup, think nobody will need IDE in new computers...

    2. With this setting boot from USB will not work. Why?
    One problem is in Hard Disk Boot priority setting!
    Every time you plug in the USB stick, BIOS will move it to SECOND place, *after* regular hard disc! So yes, it will detect it but it will boot from HDD because HDD will be the first in priority. First/Second/Third boot device options are completely ignored! Selecting boot device with F12 also do not work!

    3. But if you enter into BIOS before boot with USB plugged, you can move USB stick into first Hard Disk Boot priority setting and save BIOS. Yipee, it will boot. And will work, reset after reset - until USB stick is unplugged again. Then BIOS will forget Hard Disk Boot priority settings and erase USB stick from that option. So stick will not work unless you go to that option in bios again. VERY annoying.

    4. Additional problem - with AHCI enabled and IDE disabled BIOS will not recognize ANY bootable CDROM! For some reason I can only boot from original XP boot disc, but not with any other bootable CDROM.

    If only Gigabyte will fix it,or at least fix Hard disk boot priority forgetting USB stick from first place in the list...I do not want to disable AHCI or enable IDE every time just to be able to boot from USB!!
    Regards, VS.


    BTW, is there any way to speedup SATA AHCI detection countdown? It waits about 10secs counting little ... dots and then continues.

  2. #2
    Join Date
    Jun 2008
    Posts
    4

    Default Re: Bug in BIOS prevent booting from USB stick!

    Ah yes, sorry, I forgot to mention that motherboard model is Gigabyte EX38-DS4 (bios version is F3)

  3. #3
    Join Date
    Apr 2008
    Posts
    56

    Default Re: Bug in BIOS prevent booting from USB stick!

    I really don't see a problem For the flashing of the bios ??
    1) Inset USB Drive
    2) Enter Bios
    3) change Drive access to ide in bios.
    4) Select USB drive as 1st hd in boot priority
    5) save bios changes.
    6) boot up from usb & flash
    7) Enter bios & change back to normal drive access & Boot priority

  4. #4
    Join Date
    Jun 2008
    Posts
    4

    Default Re: Bug in BIOS prevent booting from USB stick!

    I know your solution works, the point is that it is a time consuming process and it should not work like that.
    Since there is an option to press F12 to boot from ANY OTHER DEVICE, I would like to use it...and I would like that option to work like it should.
    And there are other uses for booting from USB sticks, it's not only for BIOS flashing...
    Regards

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Bug in BIOS prevent booting from USB stick!

    Are you sure that if you leave the USB stick in and reboot, then try to boot to it or Qflash that it does not work?

    I just ask because I know if you try to flash with usb thru qflash and put the usb in after you are in qflash it wont be seen, so it has to be in there on reboot.

    Just wondered if you are trying to insert these devices after bootup? If not, then dont mind me just putting in some info

  6. #6
    Join Date
    Nov 2009
    Location
    CARACAS
    Posts
    1

    Thumbs down Re: Bug in BIOS prevent booting from USB stick!

    I don't know if this is a bug or a deficiency of the BIOS. Most other mobo brands and manufacturers allow to boot directly to a USB device by entering a BOOT MENU and decide from which device you want to book without the hassle and annoying of entering BOOT SETUP and configuring boot device priority.

    I think this issue is a dumb thing that BIOS programmer at GIGABYTE (or wherever) must take into account.

    In my personal experience, I can boot from a USB pen drive by hitting BOOT MENU and selecting the device on an ASUS MOTHERBOARD but not such a thing I could do under a GIGABYTE Motherboard.

    Specs:

    Motherboard Manufacturer: GIGABYTE
    Model: EP45-UD3P
    BIOS version: F9


  7. #7
    Join Date
    Apr 2008
    Posts
    56

    Default Re: Bug in BIOS prevent booting from USB stick!

    It does work you can boot and flash from a usb drive.

    See above post
    I really don't see a problem For the flashing of the bios ??
    1) Inset USB Drive
    2) Enter Bios
    3) change Drive access to ide in bios.
    4) Select USB drive as 1st hd in boot priority
    5) save bios changes.
    6) boot up from usb & flash
    7) Enter bios & change back to normal drive access & Boot priority
    Gigabyte X48T DQ6, E8400, 2GB CellShock DDR3 PC3-15000 1866MHz, 8800 GTS, 4x80Gb Matrix Raid + 2x 500gb , Lian V2000+, wter cooling

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •