Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Enable AHCI without reinstalling XP?




  1. #11
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Enable AHCI without reinstalling XP?

    Are you using Vista or still XP as originally stated? If not you will not have ANY luck ICH9 will only be able to use AHCI features on Vista. You would need a ICH9R board to enable it on XP.

    To enable hot plug capability for the SATA connectors controlled by the ICH9 South Bridge, you must install Windows Vista (on ICH9, hot plug is supported in Windows Vista only)
    GIGABYTE - Product - Motherboard - Specification - GA-P35-DS3 (rev. 1.0)

    Sorry!

    Like the others, I first overlooked the fact that you are using XP. And also that you have the ICH9 and not the ICH9R. Only the ICH9R would let you do this in XP.

    I did however find this, which seems to contradict all of that.... SO I am am not sure now? >>>
    How to enable AHCI on Intel ICH9 under XP

    Full Thread with user comments, not part of the FAQ listed above >>
    http://www.msfn.org/board/How-to-ena...X-t109450.html

    And I see that Exact Method posted at many sites, so it must work. No one has said otherwise, and many said thanks

    And is IS different then the one linked above although it looks similar. So read it all a few times, then go at it step by step
    Last edited by Lsdmeasap; 09-30-2008 at 12:56 PM.

  2. #12
    Join Date
    Sep 2008
    Posts
    10

    Default Re: Enable AHCI without reinstalling XP?

    I'm not sure I understand what you guys are saying with this.

    I have the EP35C-DS3R. I installed Vista 64 with AHCI disabled. Later, I enabled AHCI in the BIOS and Vista has had no issue booting. Is this just an XP issue?

  3. #13
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Enable AHCI without reinstalling XP?

    Yes, and no. It is a XP issue for starters because XP has no built in AHCI drivers and vista does. And no the main issue here is he is planning to do this on a DS3 not a DS3R, which has only the ICH9, and not the ICH9R.

    Intel/Microsoft did not release ICH9 AHCI drivers in a attempt to force users to get a board with ICH9R on it if they want to use AHCI

    It can be done though, as noted above

  4. #14
    Join Date
    Sep 2008
    Posts
    27

    Default Re: Enable AHCI without reinstalling XP?

    My bad, it's actually a GA-P35-DS3P, I've not had any luck getting the above working though, I'll try again later :)

  5. #15
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Enable AHCI without reinstalling XP?

    Ya, those last few links I gave you should work. Thats alright about the DS3P instead of DS3, you still have the ICH9 chip either way.

  6. #16
    Join Date
    Sep 2008
    Posts
    27

    Default Re: Enable AHCI without reinstalling XP?

    Cheers :)

  7. #17
    Join Date
    Jul 2009
    Posts
    1

    Default Re: Enable AHCI without reinstalling XP?

    I also have a P35-DS3 and tried installing based on this guide here:
    HOWTO: enable AHCI mode after installing Windows - PC Perspective Forums
    It worked after i replaced the Device ID of 2922 with 2923 in the ahci.reg file (just replace all 2922-s with 2923), i also did this in C:\Program Files\Intel\Intel Matrix Storage Manager\winall\Driver\iaAHCI.inf.
    Installing the intel driver by running the exe did not work, it said "This computer does not meet minimum requirements for installing the software", so I had to install the drivers by selecting "Install from disk..." in the new hardware wizard.
    Hope this helps.

  8. #18

    Default Re: Enable AHCI without reinstalling XP?

    The need for edit explained by:

    # vendor: 8086 ("Intel Corporation"), device: 2922 ("82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller")
    # vendor: 8086 ("Intel Corporation"), device: 2923 ("82801IB (ICH9) 4 port SATA AHCI Controller")

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •